2

Ant Miners are LOUD, so I wanted to put mine in the (environmentally controlled) garage. However Ant miners only have an ethernet port, and I had no good way to run ethernet from the router to the garage.

I purchased a BrosTrend AC1200 WiFi to Ethernet Adapter. Configured it, plugged it into the garage, and hooked the AntMiner to it. I discovered that the AntMiner could not reach the BTC mining pool unless I had the BrosTrend in the DMZ.

For whatever reason, I can't get my D-Link router to properly 'reserve' an IP for the BrosTrend, so every now and then it gets a different Local IP, which isn't what is in the DMZ, and the miner is cut off. Today putting the BrosTrend back in the DMZ after the latest IP address change didn't resolve the issue.

The router is a D-Link WiFi Router AC1900 (DIR-1950-US). I am hoping someone would know what feature or setting is on the router that stops it from connecting without being in the DMZ. Nothing is jumping out at me.

Can Port Forwarding fix this? If so, what are (or where would I find) the port information that I need to direct traffic from/to. Or if anyone knows what other setting is causing the problem. Thanks all!

1 Answer 1

1

You shouldn't need port forwarding for a client machine (i.e. the AntMiner) to access the internet. What pool is the miner connecting to? You would only need port forwarding if you intend to access the miner's management console from outside your local network (i.e. from a computer on the Internet).

The wireless bridge should be transparent - i.e. the bridge itself shouldn't have an IP address - it should just be sending Ethernet packets over the WiFi connection, including DHCP requests.

Putting the AntMiner in your DMZ is probably not a great idea, since that would expose it to the internet outside of your firewall. If you insist on having it in the DMZ, then configure the AntMiner to use a statically assigned IP address in the DMZ instead of using a DHCP-assigned IP address.

8
  • Thanks Hannah, With the BrosTrend adapter, it is what my router sees (it doesn't see the IP address that the BrosTrend gives to the Ant Miner). When I hook the Ant Miner directly to the main router in the house, the DMZ is not needed. It only seems to require it when going through the BrosTrend. Here's a link to the product if that helps - brostrend.com/products/e1 (also sorry for the edit. I hit enter to do a return & it posted the single sentence!). It's connecting to a pool I have through BTC.com, I'm not sure what other details you'd like that wouldn't be frivolous. Oct 18, 2023 at 17:56
  • Make sure the BrosTrend is in "Repeater" mode, not "AP" or "Access Point" mode, which should make the BrosTrend function as a wireless bridge. In repeater mode, the BrosTrend should be invisible, and make the router think your AntMiner is directly connected.
    – Hannah Vernon
    Oct 18, 2023 at 18:09
  • I asked about the pool just to make sure you aren't being conned by someone - it's a bit suspect that you need to put the AntMiner in the DMZ since that could potentially allow someone to connect to your miner from outside your network.
    – Hannah Vernon
    Oct 18, 2023 at 18:13
  • 1
    Thanks Hannah!! I will get back into the settings for it and make sure I didn't set something up wrong. I figured it needed to be in AP mode so the ethernet port would function as a LAN connection for the Ant. I may have very well misunderstood the directions, so I will play around with it and reach out to their tech support if needed. Thank you for all your help! Oct 24, 2023 at 19:44
  • @MathematicalFawkes - I just realized I may have misunderstood when you mentioned the DMZ. I assumed you were talking about the DMZ of the internet-connected router, but now on reading your above comment I realize maybe you meant you had to put the AntMiner in the DMZ of the BrosTrend. If you were talking about the BrosTrend's DMZ zone, then putting the BrosTrend into Bridge mode instead of AP mode would likely completely solve the problem you're having. Let me know, and I'll clarify my answer to reflect your real situation. Thanks 🙂
    – Hannah Vernon
    Oct 24, 2023 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.