1

I am building different tx types on regtest and don't want to care about tx fees.

Here is my bitcoin.config

fallbackfee=100000 paytxfee=100000 maxtxfee=100000 mintxfee=0.1 maxfeerate=100000

I have set the values absurdly high, but bitcoin core still doesn't allow to send a transaction (P2WPKH, 1 input and 1 output) with 100 btc in fees, and still get

Fee exceeds maximum configured by user (e.g. -maxtxfee, maxfeerate) (code -25)

1 Answer 1

2

Solved. Despite definition in bitcoin.config, when calling sendrawtransaction we need to pass again the maxfeerate

sendrawtransaction raw_tx_hex 1000

2
  • 2
    maxtxfee is a wallet configuration option; it doesn't apply to sendrawtransaction as that isn't a wallet RPC. Commented Dec 4, 2023 at 16:20
  • Did this really bypass it? I'm trying to use it and get: "Fee rates larger than or equal to 1BTC/kvB are not accepted". I'm using with "sendrawtransaction ra_tx_hex 100000". Commented Apr 30 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.