0

I have: server=1 daemon=1 in the config, bitcoind running as user as well as bitcoin-cli, no special config or anything - when I try to use bitcoin-cli it wont connect to 127.0.0.1:8332, bitcoind is synced to tip and running fine, what's wrong? Do I need to configure something regarding firewalls manually?

Full config:

proxy=127.0.0.1:9050
bind=127.0.0.1
listen=1
listenonion=1
server=1
daemon=1

./bitcoin-cli getblockchain

produces

error: timeout on transient error: Could not connect to the server 127.0.0.1:8332 Make sure the bitcoind server is running and that you are connecting to the correct rpc port.

13
  • Please update your question with the exact commands you are running, and the output you see. Dec 15, 2023 at 18:05
  • Done sorry about that
    – BobbyJones
    Dec 15, 2023 at 18:13
  • How do you start bitcoind, and does anything appear in the debug.log? Dec 15, 2023 at 18:13
  • I start bitcoind with a systemd service, the config for that I have is here github.com/bitcoin/bitcoin/blob/master/contrib/init/… but obviously to replace basic info such as user/group, datadir, etc. The daemon itself is functional and synced to the tip, sitting int he debug.log I can see it's working as intended. I just cannot connect to the daemon with bitcoin-cli for some reason
    – BobbyJones
    Dec 15, 2023 at 18:18
  • If it's relevant I'm using debian12, it was just a fresh install out of the box, I don't have anything custom on the machine. The only thing different would possibly be my exfat externalhdd that is mounted as user:user to match it running with the running user for bitcoind
    – BobbyJones
    Dec 15, 2023 at 18:25

1 Answer 1

0

The issue is that you have a settings.json file with "server": false, disabling the RPC server. This file takes precedence over bitcoin.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.