0

I have a machine (192.168.1.66) on a local network serving Electrs that's syncd to the tip (netstat -ntlp shows that electrs listening on 127.0.0.1:50001). But I have another machine (192.168.1.68) using SparrowWallet/ElectrumWallet that cannot connect to the machine hosting Electrs (e.g ./ElectrumWallet --server 192.168.1.66:50001:t will not connect/ SparrowWallet shows connection refused), what could be the problem? I am also wondering if using electrs as a trezor backend requires encryption or it can be running unencrypted

1 Answer 1

0

You might need to add this into your Electrum Server config file:

electrum_rpc_addr="0.0.0.0:50001"
7
  • I assume you meant the config file provided when you start up the electrs binary (which is in my ~/.electrs/electrs.config) but I did make that change and it didn't seem to help
    – BillyT
    Commented Dec 16, 2023 at 19:32
  • @BillyT Did you restarted the electrs after the change, right? Weird, I had a similar issue and this fixed for me. What is the output of this command on the other machine $ telnet 192.168.1.66 50001?
    – jaonoctus
    Commented Dec 16, 2023 at 20:04
  • Unable to connect to remote host: connection refused for telnet on a different device. Though on the same machine hosting electrs I can telnet 127.0.0.1 50001 and connect
    – BillyT
    Commented Dec 16, 2023 at 20:21
  • Sure, on the same machine it should work. Are you running any firewall like ufw or something like that? If so, enable the port
    – jaonoctus
    Commented Dec 16, 2023 at 21:14
  • 1
    I found the problem, such a stupid mistake. The systemd service I had was running arguments in the execution path which overwrote the config I supplied so nothing was changing, it works fine with 0.0.0.0:50001, however now I am trying to connect but it's taking a very long time and ends up with Retries exhuasted at least for sparrow wallet, the machine is pretty horrible (old random laptop that even lags when rdp'd into) I assume this is just a hardware problem?
    – BillyT
    Commented Dec 16, 2023 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.