1

My router is behind a CG-NAT protocol.

I suspect this given my WAN IP and my public IP are different.

This prevents me from running a full listening node given that my public IP is not uniquely identifying me.

As a result exposing port 8333 on router does not permit inbound node connections.

Hence I can run a fully validating node but cannot run a listening node as I am unable to receive incoming requests.

Bitcoin Core v22.0.0 - 70016/Satoshi:22.0.0/
        ipv4    ipv6   onion   total   block
in         0       0       0       0
out       10       0       0      10       2
total     10       0       0      10

I find being a leech deeply unsatisfying.

To address this I tried using a cloudflare tunnel to expose the server running my btc node. cloudflared config below:

tunnel: <my_tunnel_id_string>
credentials-file: /home/me/.cloudflared/<my_tunnel_id_string>.json
ingress:
  - hostname: dashboard.<my_domain>.online    
    service: http://192.168.20.16:8333
  
  - service: http_status:404

warp-routing:
    enabled: true

The cloudflare tunnel is working successfully. I am able to expose a nextcloud instance on port 80 for example, but I still cannot get my node to accept inbound connections.

This problem is driving me mad.

Help appreciated.

1
  • Many thanks for suggestions. Got node running over tor and now able to successfully make inbound connections. Followed below links for setup: stackexchange and wiki
    – godwrought
    Jan 8 at 0:20

0

Browse other questions tagged or ask your own question.