2

The problem: I'm getting "Method not found" when running bitcoin-cli getwalletinfo on a new install.

I've compiled and installed Bitcoin Core 26.0 from source on a Ubuntu system, following the standard method:

./autogen.sh
./configure
make 
make install 

I had to install a few missing modules (including gcc) but once done everything seemed to work correctly, and bitcoind is now happily downloading the blockchain. I didn't specify any additional commands to the configure script. However when I run bitcoin-cli getwalletinfo I get 'Method not found'.

If I run bitcoin-cli help |grep -i wallet then no results are returned.

I've checked and the disablewallet line in my bitcoin.conf is commented out. I tried flipping it to 0 just in case, no difference.

Looking in config.log in the build directory, I see this:

configure:34644: checking whether to build bitcoin-wallet
configure:34654: result: yes
...
configure:34826: checking if wallet should be enabled
configure:34837: result: no

Is this what's causing the problem, and if so, how do I fix it? Or if not, what else should I be looking at?

2 Answers 2

4

./configure will autodetect which dependencies are available on your system and it will enable or disable optional features accordingly. The wallet is one such feature. As the wallet depends on sqlite, and optionally on bdb, if neither dependency is available on your system, configure will setup a build that does not include wallet functionality.

This problem can be resolved by installing sqlite, reconfiguring, and recompiling.

1
  • In my case I installed BerkelyDB and recompiled. sudo apt-get install libdb++-dev libdb-dev Wallet functionality now supported.
    – Pyromancer
    Mar 1 at 19:29
0

I installed sqlite3 libd++-dev libdb-dev and then ran

make clean
sudo make uninstall

Still not getting wallet options on re-running bitcoin-cli help on signet. Not sure what the error is now.

Apparently I had to add sqlite3.pc in my PKG_CONFIG_PATH , got that from looking at logs at config.log

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.