I had been using my Bitcoin client for months on my Windows computer running XP.

One day, I have trouble connecting to anything else on the internet, but my Bitcoin client seems to be running okay. When I restart my computer, my internet eventually comes back, but I've had "0 connections" to the Bitcoin network for the past 2 weeks since.

I tried sending a test payment, and that payment was deducted from my wallet, but it never got broadcast. I figure it will get out once I finally figure out my connection issues.

I have my wallet backed up on a flash drive, but loading up that wallet data did nothing to help me establish network connections.

I am NOT stuck syncing. I'm just not connected or syncing at all. Everything else on my computer is otherwise running fine.

  1. What is the best address and port to connect to? Are there good backup options?

  2. If all of my addresses are correct, how do I figure out why I have 0 connections to the Bitcoin network, and how can I either reset those connections or otherwise get up and running again?

3 Answers 3


By using process of elimination , I would do something like this.

First, I would reinstall your Bitcoin wallet and see if it works. If it works properly, there was probably a Bitcoind configuration file that was messed around with in your original installation or you were using an outdated version.

If it still doesn't work, install a Bitcoin wallet on another computer on your network and see if it works. If it works, than probably there was something wrong with the Windows configuration (maybe firewall or antivirus program is blocking access). If it doesn't work, there is something wrong with your network (may be problem in your router, or internet provider)

On a side note, I wouldn't recommend running a wallet on Windows XP if you plan to keep any Bitcoins on it, due to it being incredibly insecure since Windows stopped supporting it.


This is a weird problem. I have seen it cut you off if you don't have IPv6 and the IPv4 to IPv6 virtual bridge (a service) running in the background, even if you don't have an IPv6 router nor IP and subnet address listed in your modem.

Also, if you're using Bitcoin-Qt, make sure you have the most recent version of the wallet and Pooler's CPU miner (minerd) installed, that can cause a problem too.

What I suggest doing is contacting the pool owner and find out if there is a problem with a said port and protcol, many people use Scrypt algorithm and not SHA256D anymore (unless you use ASICs) and they don't use the GETWORK protocol and port, they use the Stratum+TCP, which is default by many sites now.

This might be your problem.

Turn off or unplug your router and modem.

Drop to DOS and key this in at the prompt and hit ENTER.

ipconfig /flushdns

Plug in your modem first and wait for it to initialize and connect to the Internet.

Plug in your router and let it do it's thing and when it's up and running, type this at the command prompt and hit ENTER when done.

ipconfig /renew

After that's done type in the following and hit ENTER.

ipconfig /all

That will give you all your connection related data for a renewed adapter and cleared DNS cache.

Sometimes the cache can get old and not have the correct routing information in it which can load to "Destination is not reachable" or similar messages, like the JSON errors in the minerd.exe and ultimately Bitcoin Qt wallet with integrated mining option.

There are quite a few things that can trip this up, perhaps this will solve it for you.


You can set the addnode=IP-OF-A-NODE in the bitcoin.conf file, you can get nodes from https://blockchain.info/hub-nodes .

To solve your issue first make sure that you firewall and pc config is correct to be sure that the issue is related to the bitcoin client.

  • 1
    link leads to an empty page.
    – Gus
    Commented Dec 28, 2015 at 2:39
  • The page is not empty. It seems the database connection on this page is temporarily down,
    – Aurigae
    Commented Dec 28, 2015 at 2:50
  • If you choose to define empty as 404 or zero bytes, yes you are correct it is not actually empty. However, I was trying to solve a problem, and from that perspective the semantic difference is entirely irrelevant. Given that the table is still empty days later, It's looking very much like it's a dead page (the stealthy evil twin of a "dead link").
    – Gus
    Commented Dec 30, 2015 at 19:21
  • May i hint you the post was from february 2014, thx for downvoting anyways. My guess is blockchain.com disabled the page for security concerns. May contact them directly for clarification.
    – Aurigae
    Commented Dec 31, 2015 at 0:30
  • I did not downvote.
    – Gus
    Commented Dec 31, 2015 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.