I have been having some trouble with mining. I have no OpenCL compatible hardware, so that severely limits the software I can use (for example, GUIMiner only allows OpenCL). Is there a way that I can mine bitcoins without an OpenCL compatible CPU or GPU?

I have a Mobile Intel® 4 Series Express GPU and an Intel Pentium dual-core CPU 2.3 GHz (both have the drivers updated to the most recent relase). I have tried to install OpenCL, but my hardware doesn't support it. I have looked around and CPU mining is what seems to be the answer, but I get errors with a lot of miners. I have heard that the bitcoin wallet software can CPU mine, but to my knowledge you can only mine whole blocks not in a pool and a whole block is unreasonable with my setup. Is my current setup not able to mine bitcoins?

1 Answer 1


You can use Pooler's CPU miner (right side, download zip link), also known as Minerd. You may need to install Visual C++ on your system.

It is easy to find and download, does not use OpenCL (programming extension for graphics cards). With the mobile, I will assume that it is a laptop so CPU mining will make it really hot. Keep in mind if you do have PCIx16 there are versions of the slot that will make it not compatible with newer graphics cards. I currently have a system with version 1.0a and an older ATI version 2.0 card is not even seen to be plugged in on that board and works great in another system.

There is a limit for mining with how long Bitcoin has been out as to profitability. With pooled mining, CPU mining can be done with a Stratum Proxy run on your system as a form of buffer for mining to cut down the traffic (also known as get work requests) Minerd will do. It may take months or years before your first coin, but it can be done. Check your CPU by looking at the list of Intel CPUs here for expected rates with Minerd.


Others will tell you at the beginning that it's not enough to be worth having the systems tied down doing all that hashing due to power costs. They don't get the big picture and would not think of things like Build your own supercomputer out of Raspberry Pi boards.

With the Raspberry Pi running Minerd, each would get around 0.46 Khash/sec, so a 32 unit cluster would be estimated 15.36 Khash/sec at less than the power for the system to read this posting.

The option of upgrading to a newer system with a mining capable card, keeping what you got and getting more of them running Minerd, or some other option is open.

The ' big ' issue for mining is more than the hash rate your systems can do. It is if you can afford the power while it is mining. I have yet to see threads dealing with the new power generating tech out there that can power the mining rigs.

See Tiny, Plastic Wind Turbines Suitable for City Dwellers as an example.

I hope this answers your question and then some.

  • I downloaded cpuminer and Tried it and I got the follow error message picpaste.com/Capture-aoItBUi9.JPG It might be the PCI slot problem you mentioned. Thanks for the help.
    – markd
    Commented Aug 23, 2013 at 22:44
  • It did start up correctly and start each core of your CPU with out telling it WHAT to connect to with the command line arguments, it was trying to connect to a STRATUM server program on your system ( is local only IP port 9332 port to connect for sha256 but defaulted to scrypt ) github.com/slush0/stratum the stratum server program you run first to connect and lower the network access to a pool. Read the comments with it on the command line codes to connect to pools, how to force it to use your miner's password/user name and then try again for Minerd.
    – nybbler905
    Commented Aug 24, 2013 at 2:25
  • ' Run "minerd --help" to see options ' is in one of the readme files with the version of cpuminer I have. You did not say what operating system you are using and I have moved from windows to Linux and find it closer to the old DOS days ( and more fun ) than I care to admit. Creating a form of .BAT file was my answer to clicking one thing and getting the mining started. In Ubuntu it is 2 files with the extention dot SH and made to run as a program.
    – nybbler905
    Commented Aug 24, 2013 at 2:34
  • Thanks after alot of toying around with .bat files to configure things with the stratum proxy and the mining software I finally got it to work
    – markd
    Commented Aug 25, 2013 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.