10

I've got some trouble using bitcoin-qt.

It stays on: "No block source available... 242 weeks behind." And "Catching up ... Processed 0" etc... Map port using UPnP is activated, and proxy disabled and I have 7 active connections to the Bitcoin network. I tried without firewall or antivirus, but nothing happened. I went into log file and I saw this:

send version message: version 70001, blocks=0, us=1**.***.**.***:8333, them=*.**.****.**:8333, peer=*.****.***.****:8333
socket recv error 10054
disconnecting node 124.1

Don't take attention to the "*". For each send in the logfile there is a socket recv error...

Edit :

I'm running

bitcoin-qt v0.8.3-beta
OS - windows XP pro sp3
I tried to put it off / on -> nothing else

What can I do? Thank you for your help.

  • I believe I am ecountering the same issue. I am on a mac, & I've tried locating the "bitcoin" folder under the "Library Support" folder as I have read on another page to delete the program files to re-install it but I am unable to locate it. Says "No block source available" upon hover "Catching up... 180200 out of 225430 (estimated) blocks of transaction history last received block was 67 weeks ago... says I have "0 active connections to the bitcoin network" it has been at this state for more than 12 hours... any help? – nicholas Aug 31 '13 at 20:57
  • what is the posts 1 2 very helpful. – user12008 Jan 10 '14 at 2:34
2

I was having this problem. I updated my client to the newest version (https://bitcoin.org/en/download) and it solved itself. I think the clients might stop communicating with other clients who don't update. Haven't read that anywhere or anything, just a guess.


The problem has returned, but updating the client is still a good thing to do.

1

You could try to:

  • Download the blockchain as a file and import it
  • force your client to switch to other peers
  • have you tried turning it off and on again?
  • have you tried reinstalling it?
  • have you tried putting your computer into another network?

Otherwise more information about what you have tried would be helpful, and we could use a bit more information such as, which version of the client and what operating system you are using. :)

Edit: Just googled your problem again and found a bug report from 2012 where a person had "socket recv error: 10054". Somebody suggested the following (Please read the whole thing before applying!):

Take a look at (folder is hidden):

C:\ProgramData\boost_interprocess\Select LastBootUpTime from Win32_OperatingSystem

This one contains 2 files, 1 which consists of 32 "random" characters and looks like a hash and a BitcoinURL file of size 0. The files are there sometimes after a hard crash.

Delete the whole C:\ProgramData\boost_interprocess folder, restart the client, remove the database logs from the datadir and everything will work again.

It's related to stale files after a crash, which seem to come from a used lib in the Bitcoin client (some of the Boost ones).

To which the thread starter replied that it solved his problem.

MacOS

According to a comment on a similar question by Neil Neyman the respective folder can be found on MacOS at ~/Library/Application Support/Bitcoin/

To show your library directory in finder, hold the alt key while viewing the "GO" menu in the top menubar.

  • How can i force the client to switch to other peers ? Thanks for your help ! – Postnop Aug 28 '13 at 7:13
  • You can create a configuration file in your Bitcoin folder, and you'll want to use addnode=ip.ad.dr.ess. You can find instruction here: Running Bitcoin: Configuration File Otherwise I wonder, whether it might be a Windows XP problem, I mean even Service Pack 3 is five years old by now. ;) – Murch Aug 30 '13 at 13:50
  • You were probably right, changed it for W7 and no more trouble. Sorry for the delay, was on holidays. – Postnop Oct 14 '13 at 14:19
1

I had this same problem and I found these two posts 1 2 very helpful. What ended up working for me was going to preferences > Network, and turning off the SOCKS proxy, and then restarting the program. After that the network started to synchronize.

  • Loourr, You solution worked for me. Thanks. However, is it important that I have Socks Proxy turned on - on my own home network? – user1043582 Jan 12 '14 at 16:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.