0

So I have setup bitcoind -daemon on a server. On plain HTTP, I can connect to the server from my machine and start mining with poclbm.py (at a slow rate but I am preparing my environment before upgrading H/W)

Then I have created the self-signed certificate successfully, and from a remote machine I can get the SSL certificate validation using openssl s_client command. I had trouble with the openssl s_client command when not including the

rpcsslciphers=TLSv1+HIGH:!SSLv2:!aNULL:!eNULL:!AH:!3DES:@STRENGTH

part in the conf, but after adding it it as ok.

Then added option rpcssl=1 in bitcoin.conf.

Now I get a Failure to subscribe followed by IO errors - 1, tolerance 2.

Is there anything else to check? Running poclbm with -verbose doesn't show more output.

1

After looking at the (quite old) source code of poclbm, there is a commented line that creates the SSL connection. Not sure it is the reason but I guess it doesn't support HTTPS in its last version. I changed to DiabloMiner (I had to add my self-signed certificate using the InstallCert.java tool)

I can now mine over HTTPS. Next step is a pool...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.