4

I'm using Windows 8 x64. I've downloaded the latest cgminer (3.4 at this time), but when ever I try and start it I get the error message:

Error opening terminal: dumb

I've seen various post that suggest this relates to the TERM env var and setting this does change the message to end with what ever is in TERM, but nothing I've tried fixes it. Anyone know what I need to do to get this working?

7

I had the same problem and for me it worked to set the TERM variable to nothing directly before you execute cgminer. Like this in the cmd shell:

set TERM=
cgminer-nogpu.exe ........

If you set it to "" (meaning nothing) in the system settings it will use the default value "c:\windows\system32\cmd.exe". You can check the the variable in the shell with:

echo %TERM%

I hope this will help you :)

  • Wow, thanks! I'd tried setting TERM to just about everything but the empty string! – Robert Oct 24 '13 at 7:48
  • Sure, forget about that sorry. – Robert Dec 3 '13 at 14:24
  • 1
    This seems kinda coincidental and doesn't get at the root of WHY that error message is being produced. It also doesn't work for me: $ TERM='' ./cgminer --scrypt -o stratum+tcp://dogehouse.org:3333 -u zbuc.zbuc -p p4ssw0rd --worksize 256 --lookup-gap 2 --thread-concurrency 2047 -g 1 --intensity 11 Error opening terminal: unknown. – ashgromnies Dec 19 '13 at 19:52
2

Start the cgminer script with the -T flag. That worked for me. It disables ncurses and uses text-only output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.