Recently I have reinstalled Bitcoin qt because my HDD crashed. Fortunately I had a backup of my wallet.dat, but there is still one problem.

After the installation I replaced the wallet.dat with my old wallet.dat. If I start Bitcoin qt now, I can not see any money in my wallet?!

What can I do now?

  • 1
    Have you tried running bitcoin-qt -rescan? Oct 8 '13 at 18:32
  • Yes, also tried this. It didn't work. Oct 8 '13 at 19:11
  • Do any transactions show at all? If not, you probably didn't have a good backup. Oct 8 '13 at 22:58
  • How recent was your backup? Bitcoin-Qt/bitcoind uses a keypool, and thus you need to make new backups after a certain number of transactions. Oct 8 '13 at 22:58
  • I even can't see any transactions listed in my client. Bitcoin-qt looks like if I have started it the first time. I am sure the backup includes the latest transactions, I just created it some days before the crash happened. Oct 9 '13 at 11:37

Are you also sure that you've let Bitcoin qt fully synchronise with the network? Very recently I moved across my wallet.dat to a new installation with no issues.

  • I am 100 percent sure, I really don't know what's the problem. It's a pity that I have lost my Bitcoins now. Oct 9 '13 at 11:29
  • 3
    I'm quite unsure then. Why don't you enable debugging and take a look at debug.log. Maybe it'll tell you where it's going wrong and if it's failing to load wallet.dat. Oct 9 '13 at 13:38

Check your wallet address against blockchain.info. verify there are no erroneous transactions / that your using theright wallet.dat file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.