2

Basically I'm trying to keep a wallet on linux along with the RPC service so I can receive coins and poll the server periodically for transactions.

I'm trying with both 0.8.1 and 0.8.5 and CPU usage is at 100%, running this on amazon and I get the same even with the xlarge EC2 instance. This has been going on for over 24 hours, had to force reboot the instance to be able to reconnect.

It's not even set to generate coins. gen=0

I guess I'd like to know if this is permanent, or a bug, or something I'm doing wrong? Or maybe it just takes a while to "sync" or whatever its doing then it will go back to "normal" and by normal I mean any level of CPU usage that isn't in the range of WTF and OMG.

Also tried sending myself some 0.01-0.05 btcs and they never made it. Maybe it takes a while to show up? Although blockchain says said transactions have over 100 confirmations.

TIA

3

From the description you are giving it sounds like you haven't yet synchronized with the network. Before you can start doing anything useful, e.g., see your current balance, the bitcoind client downloads the entire blockchain and verifies it. This may take quite some time and will likely keep your CPU busy until its done. You can check the progress of the synchronization by issuing a bitcoind getinfo and checking the blockchain height with blockchain.info or similar site.

  • 1
    Thank you so much for confirming. Thought it might be something like that. – Nick M Oct 9 '13 at 19:23
0

Change ~/.bitcoin/bitcoin.conf

daemon=1

to

daemon=0

And use this utility cpulimit:

$ cpulimit -l 10 bitcoind

This way you set bitcoind to use no more than 10% of CPU:

$ cpulimit -h
CPUlimit version 1.7
Usage: cpulimit TARGET [OPTIONS...]
   TARGET must be exactly one of these:
      -p, --pid=N        pid of the process
      -e, --exe=FILE     name of the executable program file
                         The -e option only works when
                         cpulimit is run with admin rights.
      -P, --path=PATH    absolute path name of the
                         executable program file
   OPTIONS
      -b  --background   run in background
      -c  --cpu=N        override the detection of CPUs on the machine.
      -l, --limit=N      percentage of cpu allowed from 1 up.
                         Usually 1 - 400, but can be higher
                         on multi-core CPUs (mandatory)
      -v, --verbose      show control statistics
      -z, --lazy         exit if there is no suitable target process,
                         or if it dies
      -h, --help         display this help and exit

Look at this question:

What are the alternatives to downloading the 6GB block chain?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.