0

After getting abe set up and running, I tried querying it, eg: ...:2750/chain/Bitcoin .. but looking at the abe output, I notice every page load - abe was opening the blk00000.dat file rather than using MySQL [which I have configured abe to use].

My abe.conf looks like this;

dbtype MySQLdb
connect-args {"user":"test","db":"abe","passwd":"test"}
upgrade
port 2750
host localhost

I have checked the 'abe' MySQL database and the data is in there, I am just unable to figure out why abe isn't querying that and instead opening the blk00000.dat file. . . which is making every request I make to abe unbearably slow.

So my question is: How to make Abe query MySQL instead of reading from the bitcoin block.dat for each request ?

1

I'm still loading the blockchain into my database, but are you starting Abe with the --config option pointing to your configuration file?

See line 49 in https://github.com/bitcoin-abe/bitcoin-abe/blob/master/README-MYSQL.txt

  • Yes I specify the absolute path to the config file when firing up abe, still nothing working :( – ManreeRist Oct 24 '13 at 21:34
  • Did you ever find a solution for this? I am having the same problem. – Jeff Thomas Mar 13 '14 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.