0

Ubuntu 13.10 & amd-catalyst-13.4-linux-x86.x86_64.zip

xorg.conf created by

# aticonfig --initial -f --adapter=all

Thereafter, i modify it with next /etc/X11/xorg.conf

Section "Module"
        Disable        "dri"
        Disable        "dri2"
EndSection

Start phoenix:

$ ./phoenix.py bitcoin_deepbit_gpu.cfg
[10/28/2013 02:30:08] Welcome to Phoenix v2.0.0
[0 Khash/s] [0 Accepted] [0 Rejected] [DISCONNECTED]X server found. dri2 connection failed!
Trying to open directly...Device open failed

Start cgminer:

$ ./cgminer --scrypt  -T --url stratum+tcp://stratum.coinex.pw:9000 --user user --pass pass --no-submit-stale --queue 4 --scan-time 1
 [2013-10-28 02:41:21] Started cgminer 3.6.6                    
X server found. dri2 connection failed! 
Trying to open directly...Device open failed

I have partially solve this trouble with --gpu-platform 0:

$ ./cgminer --scrypt --gpu-platform 0 -T --url stratum+tcp://stratum.coinex.pw:9000 --user user --pass pass --no-submit-stale --queue 4 --scan-time 1
 [2013-10-28 02:43:12] Started cgminer 3.6.6                    
 [2013-10-28 02:43:12] Probing for an alive pool                    
 [2013-10-28 02:43:17] Pool 0 difficulty changed to 64                    
 [2013-10-28 02:43:17] Network diff set to 0                    
 [2013-10-28 02:43:17] Stratum from pool 0 detected new block                    
 [2013-10-28 02:43:19] Found block for pool 0!                    
 [2013-10-28 02:43:21] Found block for pool 0!                    
(5s):7.156K (avg):18.36Kh/s | A:0  R:0  HW:0  WU:35.4/m
....

But what is it?

Trying to open directly...Device open failed

Why does it trying to open device disabled by module directive in the xorg.conf?

And how to specify platform for phoenix miner?

There is only one option in phoenix config:

name = GPU 0 #The name to display the device as (default is device ID if not specified)

It doesn't help.

3
  • Could you please clarify what exactly your question us? – Murch Oct 29 '13 at 9:34
  • Check, I'm trying to clarify it for you. – bellicose Oct 31 '13 at 23:11
  • Do you have intel gpu?? try "sudo apt-get remove beignet" – user10627 Dec 11 '13 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.