Last time I used my Bitcoin-qt client was a few months ago. I made a backup of the wallet to an external USB drive.

Yesterday, I started the client and after it synchronized the block-chain, I saw that I had 0 bitcoins! I restored the backup wallet.dat file and started it again, it said it was rescanning, and then the same result: 0 bitcoins! Even the transaction history is blank!

I had once done a paper backup but cannot find that now. Would that help?

Is there a way to know if I was hacked and my btc stolen?

Help... any advice and hints appreciated!


If your bitcoins had been stolen (by someone else who acquired the private keys), your client would show transactions sending those coins to the thief's address. The fact that you see no transactions at all suggests that for some reason the client has not imported the keys correctly, or perhaps that your backup is corrupt.

If you know the addresses from your wallet, you can look them up on a site like http://blockchain.info and see if the coins are still in those addresses, or if they have been transferred out.

  • I hope he did not delete the wallet.dat when importing the other from the USB – rdymac Oct 28 '13 at 0:54
  • no I did not delete the old wallet.dat, I renamed it first before copying the one from the USB. btw: my transaction history is empty in both .dat files! – user7321 Oct 28 '13 at 6:13
  • Nate, you said that perhaps "the client has not imported the keys correctly"! Where are these keys? How can I check them? – user7321 Oct 28 '13 at 6:51
  • 1
  • I ran the client with the -rescan parameter but when it finished it still showed 0 bitcoins and no history! :-( – user7321 Oct 28 '13 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.