7

So I am trying to install cgminer on my debian server. I've downloaded the latest nVidia drivers, tried many things but still can't get this work. So this is the end of the log from autogen.sh:

config.status: executing libtool commands



------------------------------------------------------------------------
cgminer 3.6.4
------------------------------------------------------------------------


Configuration Options Summary:

  libcurl(GBT+getwork).: Enabled: -lcurl
  curses.TUI...........: FOUND: -lncurses
  OpenCL...............: Detection overrided. GPU mining support DISABLED
configure: error: No mining configured in

I've already tried to download the latest CUDA toolkit, but it didn't work either. On google I just found solutions for ATI/AMD cards. (btw. I have GeForce GT-9600)

0
14

use ./autogen.sh --enable-opencl instead of ./autogen.sh

2
  • 1
    I also needed to install the header files (On Ubuntu: apt-get install opencl-header)
    – hknust
    Dec 7 '13 at 5:10
  • 6
    'opencl-header' should be plural: apt-get install opencl-headers
    – user11699
    Jan 3 '14 at 0:15
0

I had to install ocl-icd-opencl-dev as well before ./autogen.sh --enable-opencl

sudo apt-get install ocl-icd-opencl-dev
sudo ./autogen.sh --enable-opencl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy