20

I have searched around, and nothing I find works for me. Downloaded the approx. 10 GB Bootstrap.dat file. Now stuck on trying to link it with Bitcoin-QT.

Tried the following command in the console box in the bitcoin-qt app:

bitcon-qt -loadblock=/path/to/bootstrap.dat

Also tried copying the file into the AppData/Roaming/Bitcoin file... Still no luck.

I'm running Windows 7, anyone have step by step instructions on how to set this up?

  • 1
    Your question may be best addressed to the original post on the BitcoinTalk forum. – Colin Dean Nov 17 '13 at 10:53
  • 2
    it did help me thanks! Im running bitcoin-qt 0.8.5 on a mac os10.9 , and i downloaded the bootstrap.dat file, dumped it on /application support/bitcoin/ and the client found it and started importing blocks from disk. all G! cheers – user10459 Dec 9 '13 at 5:05
  • Any one know how to do this running windows 8 – user12597 Jan 23 '14 at 13:03
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Stéphane Gimenez Jan 23 '14 at 13:20
10

Okay, it appears after much trial and error, I figured out that you put the bootstrap.dat file in the AppData/Roaming/Bitcoin or ~/.bitcoin folder. You can leave everything else in that folder untouched, just add the bootstrap.dat file in the Bitcoin folder.

I left bootstrap.dat in there, and finally Bitcoin-QT found it, and on the bottom it states "Importing blocks from disk..." I'm currently at 80 weeks behind on the update, compared to 240+.

I was reading crap about using the -loadblock command and extracting/unzipping the .dat file.... well this wasn't needed. At least it isn't needed on the current version of QT, which I believe is .8.0.5

  • It didn't work for me. Just left in the same directory of wallet.dat and it did not work. This directory should be empty? Without any block previously downloaded? – Felipe Mar 23 '14 at 0:11
  • On Linux, I made sure the folder was empty when I put bootstrap.dat there. Also, I used a different folder, so I started bitcoin-qt with bitcoin-qt -datadir=/media/downloads/bitcoin . Probably it saved the datadir in its config file, I will check that later. – bit chaser Oct 18 '14 at 19:30
7

I tried putting blockfile in .bitcoin directory and starting ./bitcoind but doesn't works. By the way, this method works best for me.

./bitcoind -loadblock=~/.bitcoin/bootstrap.dat

You need to use loadbloack syntax with the ./bitcoind .

Not the answer you're looking for? Browse other questions tagged or ask your own question.