I am getting an error {"code"=>-5, "message"=>"No information available about transaction"} when issuing getrawtransaction.

I am aware that

since bitcoind/Bitcoin-qt 0.8, no transaction index is kept anymore by default, as it is not necessary for validation in the new database model.

( Discussed here: getrawtransaction error? [Code -5] )

I have followed the answers and rebuilt my index with --reindex. I also have txindex=1 specified in my Bitcoin.conf file.

I am still getting the same error every time. What could be the issue? How do I make sure the client keeps an updated index along with synchronising for new blocks?

UPDATE: I tried working with a random hash: "d3ad39fa52a89997ac7381c95eeffeaf40b66af7a57e9eba144be0a175a12b11" and it works. Not for all though. Is transaction data specific only to some blocks?

  • 3
    Which transaction data can't you reach? I know that genesis block coinbase transaction is not fetchable, since it is not really a valid, spendable transaction - github.com/bitcoin/bitcoin/issues/3303
    – ThePiachu
    Commented Nov 29, 2013 at 10:33

1 Answer 1


My guess is that getrawtransaction only works on utxo transactions which means outputs of that transactions are not spent and still kept index by the bitcoin client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.