3

According to litecoin.info/Mining_Hardware_Comparison, 6850 is 200+kH/s
But I run speed is 17.28K/14.39Kh/s, what's wrong??

 cgminer version 3.5.0 - Started: [2013-11-30 17:08:22]
--------------------------------------------------------------------------------
 (5s):17.25K (avg):14.28Kh/s | A:0  R:0  HW:0  WU:12.4/m
 ST: 2  SS: 0  NB: 6  LW: 45  GF: 0  RF: 0
 Connected to coinotron.com diff 256 with stratum as user xxxxx
 Block: fa394c9dc29d9325...  Diff:99.8M  Started: [17:15:04]  Best share: 107
--------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  58.0C 1206RPM | 17.28K/14.39Kh/s | A:0 R:0 HW:0 WU:12.4/m I: 8
--------------------------------------------------------------------------------

GPU 0: 16.9 / 12.4 Kh/s | A:0  R:0  HW:0  U:0.00/m  I:8
57.0 C  F: 37% (1148 RPM)  E: 775 MHz  M: 1000 Mhz  V: 1.150V  A: 96%  P: 0%
Last initialised: [2013-11-30 17:08:36]
Intensity: Dynamic (only one thread in use)
Thread 0: 17.2 Kh/s Enabled ALIVE
  • I have the same problem. – zkilnbqi Dec 3 '13 at 19:54
3

Your intensity is very low (I:8) - dynamic intensity does not work well with scrypt. You will need to increase it manually. You can set a value to use when starting the program by adding --intensity 13 to your command line options/batch file. Replace the number 13 with the desired intensity. For a HD6850, I suggest you try values from 10 to 15.

If increasing the value by one notch does not significantly raise kh/s, gives you hardware errors (the number after HW:) or starts impacting in a noticeable way on desktop performance, then reduce it again.

You can also change the intensity whilst cgminer is running. Press g, then i, then carefully type the number, then enter.

3
+50

I am using a slightly overclocked AMD 6850 and get around 270kh/s.

When running cgminer you need to set two environment variables. In windows I use a batch file with the following:

TIMEOUT 10
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer

Timeout is just there so it waits 10 seconds to make sure MSI Afterburner has overclocked the cards before starting cgminer. It is available on Windows Vista and above and can be skipped by pressing a key.

You can create the batch file by entering this into notepad, click File > Save As and on the Save as type dropdown select All files. Choose a name for the file and make sure it ends with .bat then save it in your cgminer directory. You can run cgminer by opening this batch file or create a shortcut to it.

I am using a cgminer.conf file instead of command line arguments. If you are currently using command line arguments you can start cgminer, press S for settings then press W to write a config file. Press enter when it asks for the name and a cgminer.conf will be created. By default cgminer will use cgminer.conf if it is found in the same directory. You can have several configuration files and use them by supplying the --config or -c flag in the batch file e.g. cgminer -config dogecoin.conf or cgminer -c "C:\test.conf".

If you are using two different cards you will need to adjust the settings for each one by separating the values with commas. In the config below the 6850 settings are on the left, and the settings for my 7950 are on the right.

These settings work well for me but may need to be customised for your own use. In particular the high intensity in my config means the computer is unsuitable to work on while mining but will give slightly higher hashing rates.

{
"pools" : [
    {
        "url" : "http://pool-url:3333",
        "user" : "username",
        "pass" : "password"
    },
    {
        "url" : "http://pool-url:3333",
        "user" : "username",
        "pass" : "password"
    }
]
,
"intensity" : "18,20",
"vectors" : "1,1",
"worksize" : "256,256",
"kernel" : "scrypt,scrypt",
"lookup-gap" : "0,0",
"thread-concurrency" : "4800,21712",
"shaders" : "960,1792",

"gpu-engine" : "0-0,0-0",
"gpu-fan" : "100-100,100-100",
"gpu-memclock" : "0,0",
"gpu-memdiff" : "0,0",
"gpu-powertune" : "0,0",
"gpu-vddc" : "0.000,0.000",
"temp-cutoff" : "95,95",
"temp-overheat" : "90,90",
"temp-target" : "80,80",

"api-mcast-port" : "4028",
"api-port" : "4028",
"expiry" : "120",
"failover-only" : true,
"gpu-dyninterval" : "7",
"gpu-platform" : "0",
"gpu-threads" : "1",
"hotplug" : "5",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "30",
"scrypt" : true,
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}

I am using cgminer 3.7.2 as that is the latest version with scrypt support.

These links might be helpful for configuring cgminer:
https://bitcointalk.org/index.php?topic=117221.0
http://www.brandonorndorff.com/bitcoin/mining/how-to-setup-and-optimize-your-cgminer-config-file/

  • I awarded the bounty to you because this answer was the most complete one. You might want to comment on the version of cgminer you are using and how exactly you start cgminer, and where the conf file is located. – zkilnbqi Dec 10 '13 at 11:31
1

So I set this bounty and then was able to make some progress by following

https://github.com/ckolivas/cgminer/blob/3.7/SCRYPT-README

On my 7950, without even fine tuning it, the mining speed went from 15 to 515. Using cgminer-3.7.2, this is the command I used.

./cgminer --scrypt --intensity 20 --auto-fan --gpu-powertune -10 -u hnaparst.1 -p password -o stratum+tcp://pool1.us.multipool.us:7777

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.