5

Here is my run command:

cgminer -o stratum+tcp://coinotron.com:3334 -u user -p pass --scrypt

the only output in my terminal I get is (and only this):

[2013-11-30 11:34:02] Started cgminer 3.7.2

if Ctrl+C it I finally get this output:

[2013-11-30 11:34:43] Summary of runtime statistics:
[2013-11-30 11:34:43] Started at [2013-11-30 11:34:03]
[2013-11-30 11:34:43] Pool: stratum+tcp://coinotron.com:3334
[2013-11-30 11:34:43] Runtime: 0 hrs : 0 mins : 40 secs                     
[2013-11-30 11:34:43] Average hashrate: 0.0 Kilohash/s                
[2013-11-30 11:34:43] Solved blocks: 0                     
[2013-11-30 11:34:43] Best share difficulty: 0                     
[2013-11-30 11:34:43] Share submissions: 0                     
[2013-11-30 11:34:43] Accepted shares: 0                     
[2013-11-30 11:34:43] Rejected shares: 0                     
[2013-11-30 11:34:43] Accepted difficulty shares: 0                   
[2013-11-30 11:34:43] Rejected difficulty shares: 0                   
[2013-11-30 11:34:43] Hardware errors: 0                     
[2013-11-30 11:34:43] Utility (accepted shares / min): 0.00/min       
[2013-11-30 11:34:43] Work Utility (diff1 shares solved / min): 0.00/min
[2013-11-30 11:34:43] Stale submissions discarded due to new blocks: 0
[2013-11-30 11:34:43] Unable to get work from server occasions: 0                 
[2013-11-30 11:34:43] Work items generated locally: 1                 
[2013-11-30 11:34:43] Submitting work remotely delay occasions: 0     
[2013-11-30 11:34:43] New blocks detected on network: 1
[2013-11-30 11:34:43] Summary of per device statistics:
[2013-11-30 11:34:43] GPU0     | (5s):0.000 (avg):0.000h/s | A:0 R:0 HW:0 WU:0.0/m

my GPU is properly detected:

11:34:56 me@ArchPC::~/Desktop cgminer -n
 [2013-11-30 11:36:35] CL Platform 0 vendor: NVIDIA Corporation                    
 [2013-11-30 11:36:35] CL Platform 0 name: NVIDIA CUDA                    
 [2013-11-30 11:36:35] CL Platform 0 version: OpenCL 1.1 CUDA 6.0.1                    
 [2013-11-30 11:36:35] Platform 0 devices: 1                    
 [2013-11-30 11:36:35]  0   GeForce 9600 GT                    
 [2013-11-30 11:36:35] 1 GPU devices max detected                    
 [2013-11-30 11:36:35] USB all: found 6 devices - listing known devices                    
 [2013-11-30 11:36:35] No known USB devices

What could the problem be?

EDIT: Just tried it without --scrypt... it works then, but I need scrypt for LTC. How do I fix this?

6

Apparently I do not have enough points yet to give your answer a vote, but your solution also worked for me! Adding -T to the command line command did the trick. Not only do I now get a neat output of what is happening; the -T parameter also made the entire mining process actually work!

Before adding the -T command: Screen flashed with the "Started CGMiner 3.7.2" message. No messages were shown until I pressed CTRL + C. The report said that only one share had been submitted and accepted - every time I ran CGMiner.

After adding the -T command: The screen doesn't flash any more. Everything that happens is outputted line by line to my command prompt. CGMiner is actually working and submitting shares. As we speak I'm on a total of 3616 accepted difficulty shares, contrary to 32 before.

  • +1 - Fixed it for me. For those wondering, '-T' is a shortcut for '--text-only', used to disable ncurses formatted screen output. – Francis Dean Dec 4 '13 at 13:46
1

Make sure your bat file has these two lines first

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
0

-T flag fixed this for my laptop. Something with ncurses text formatting

0

In addition to the -T workaround, I found the fix for my machine was to delete the .bin file generated. The fault was reproducible every single time if I left it alone.

Since I execute from a batch file, I just added a line before executing cgminer:

del scrypt*.bin

Naturally, this deletes any .bin files prefixed with scrypt (leaving others alone if you're mining something else using the same base directory).

0

This was my problem as well, but hated running with the -T toggle on. I found out that it had to do with the ncurses lib missing on my freshly installed Win7 system, so after I installed cygwin cgminer worked without the -T toggle and with the normal stats screen.

0

Adding --no-restart to my command fixed this problem for my 290x setup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.