1

I'm found that speed of my cgminer should be around 320kh/s:

https://litecoin.info/Mining_hardware_comparison

ati / amd radeon HD6870 GPU

The wiki recommend use this -I 19 -g 1 -w 256 --thread-concurrency 8192

However, I can not use -I more than 11, because hardware errors HW

My current success is ~ 150Kh/s:

./cgminer --scrypt --gpu-platform 0 -T --no-submit-stale --queue 4 --scan-time 1 --intensity 11 --thread-concurrency 2048 --load-balance --url stratum+tcp://

(5s):141.5K (avg):141.3Kh/s | A:631234  R:0  HW:0  WU:118.9/m
(5s):153.7K (avg):147.4Kh/s | A:1261234  R:0  HW:0  WU:141.2/m

When I set --intensity more than 11, i'm always get a hardware error and no accepted shares:

  • 12 - only errors - HW, no accepted shares:

(5s):145.5K (avg):145.0Kh/s | A:0 R:0 HW:12 WU:9.1/m

(5s):145.9K (avg):145.1Kh/s | A:0 R:0 HW:12 WU:8.2/m

(5s):147.0K (avg):145.4Kh/s | A:0 R:0 HW:13 WU:7.5/m

...

  • 16 - speed growth, but no accepted shares, only HW :

(5s):179.4K (avg):279.3Kh/s | A:0 R:0 HW:39 WU:27.2/m

(5s):226.5K (avg):269.4Kh/s | A:0 R:0 HW:54 WU:13.7/m

  • 18 - very huge desktop lag, no accepted shares, and HW growth very fast:

(5s):188.2K (avg):296.4Kh/s | A:0 R:0 HW:52 WU:0.0/m

(5s):230.4K (avg):295.9Kh/s | A:0 R:0 HW:82 WU:0.0/m

(5s):256.3K (avg):295.9Kh/s | A:0 R:0 HW:106 WU:0.0/m

(5s):271.9K (avg):295.8Kh/s | A:0 R:0 HW:126 WU:0.0/m

  • 20 - good bye Desktop. HW

(5s):273.9K (avg):287.7Kh/s | A:0 R:0 HW:194 WU:1.3/m

(5s):285.6K (avg):289.4Kh/s | A:0 R:0 HW:224 WU:1.1/m

(5s):264.7K (avg):292.4Kh/s | A:0 R:0 HW:325 WU:1.6/m

This is around declared in Wiki 320ks/s, but it is not a workable state, there are only errors - HW.

However, there is another mistake in wiki: --thread-concurrency 8192, my card have no enough RAM:

 [2013-12-02 17:02:00] Maximum buffer memory device 0 supports says 134217728                    
 [2013-12-02 17:02:00] Your scrypt settings come to 13428326

This told me cgminer, when I make +1 to --thread-concurrency 2049


What is the magical border between 11 and 12 intensity?

I do not touch default Core and Memory Clocks:

$ amdconfig  --odgc

Default Adapter - AMD Radeon HD 6800 Series 
                            Core (MHz)    Memory (MHz)
           Current Clocks :    300           300
             Current Peak :    915           1050
  Configurable Peak Range : [400-1100]     [500-1260]
                 GPU load :    8%

How can I achieve workable 320 kh/s, as wiki told?

1

Optimum hash rate depends not just on the parameters sent to cgminer but also on how was this program compiled, if it's 32bits/64bits, and the OS configuration.

The best results I've seen are with Gentoo Linux - as you may know, with this distro you first stablish your specific hardware configuration and then compile everything from code, thus optimizing all our software for the hardware you have to extract the most value off of it.

Something you do can do without going the esoteric route of OS tweaking, you could try modifying the GPU's mem clock as well as (slightly) overclocking. Usually, once you hit the point of diminishing returns with the intensity, thread-concurrency and work unit those are the next values to tweak.

If you haven't read the "README" file from Con Kolivas himself, when discussing Litecoin he delineates an optimizing algorithm in which you first find a sweat spot with intensity, then with another value, then another... finally going to mem clock and overclocking, he says you'll extract the best performance that way - such approach is valid for all scrypt-based coins.

0

Having HD6870 set up today as well, the best result I was able to achieve experimentally was around 200.6Kh/s at those settings:

cgminer.exe --scrypt -o url -u user -p pass --intensity 11 -g 1 --worksize 104 --thread-concurrency 2048 --auto-gpu --gpu-engine 1100 --gpu-memclock 1200 --temp-target 80 --auto-fan --temp-overheat 85 --temp-cutoff 90

Currently the system is running at 74-C with 0HW

Indeed it seems you can't go upper than i11 and concurrency has to be 2^11 i.e. 2048. Otherwise you will get err message about insufficiend memory. Better speed is achieved through increasing GPU and memory clock frequencies.

0

I had same kind of problems with --thread-concurrency with my three R9 290 cards. The problem was that I had only 4GB of ram, I bought 8gb more ram, total 12GB and now everything works just fine. After that I also had problems with intensity but I worked it out with correct fan and temp-target settings.

  • 1
    I had only 4GB of ram, I bought 8gb more ram, total 12GB and now everything works just fine. Are you sure? 1714m 31m 12m S 42.8 0.2 91:12.71 ./cgminer My cgminer doesn't take more than 31 megabytes of resources, however, it takes a 1714m virtually. – user9885 Jan 4 '14 at 18:34
0

There are probably problems with ATI-drivers or AMD-APP-SDK versions, please try the SMOS distribution which has tested versions.

http://www.smos-linux.org/

It worked for me :)

0

I have two HIS 6870's and they are both hitting 270kh/s at 77c with these settings: intensity 14, worksize 64, thread-concurrency 6720, gpu-memclock 900, gpu-powertune -20. Running on default litecoinBAMT1.3

sgminer version 4.0.0 - Started: [2014-02-10 20:31:11]
--------------------------------------------------------------------------------
(5s):551.1K (avg):543.6Kh/s | A:314368  R:3072  HW:0  WU:524.5/m
ST: 6  SS: 0  NB: 2039  LW: 38388  GF: 1  RF: 0
Connected to useast.middlecoin.com diff 1.02K with stratum as user ME
Block: f91ee7b2...  Diff:110M  Started: [06:46:06]  Best share: 325K
--------------------------------------------------------------------------------
[P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  77.0C 3012RPM | 272.5K/273.3Kh/s | R:  0.6% HW:0 WU: 275.4/m I:14
 GPU 1:  77.0C 2826RPM | 272.7K/270.4Kh/s | R:  1.4% HW:0 WU: 249.1/m I:14
--------------------------------------------------------------------------------
0

My setting:

--scrypt -I 19 -g 1 --lookup-gap 2 --thread-concurrency 6720 -w 64

I get:

cgminer version 3.7.2 - Started: [2014-02-14 21:28:07]
--------------------------------------------------------------------------------
 (5s):314.1K (avg):301.2Kh/s | A:79264  R:1440  HW:0  WU:270.0/m

I am using Ubuntu minimal install and it is not being used for Desktop. This is the best I could squeeze out so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.