I am running Mac OS X 10.7 on a MBP and OS X 10.8 on a Mac Mini. The Mini has a Intel HD Graphics 4000 GPU and the MBP has a 3000.

I know that I cannot mine with the MBP as the GPU does not support OpenCL. The Mac Mini should be able to as the Intel HD 4000 supports OpenCL 1.2.

However when I run:

bfgminer -n
 [2013-12-04 15:35:22] 0 GPU devices max detected

My GPU is not detected. I have the latest XCode installed as the well as command line tools and compiled bfgminer with the latest install of brew.

I just want to play around with mining and am not interested in buying an ASIC set up.

How can I get my GPU to be detected by bfgminer or cgminer?


When I run 'bfgminer --verbose' I get the following error:

[2013-12-04 17:30:57] JSON-RPC call failed: { "code": -1,
"message": "Unsupported method 'getblocktemplate'" }

  • What is the processor you are using on the Mac Mini ? Commented Dec 4, 2013 at 23:39
  • @Meterbuchus The GPU or the CPU? As I stated in the question on the Mini it is an Intel HD Graphics 4000 GPU. CPU is: 2.3 GHz Intel core i7
    – Deesbek
    Commented Dec 4, 2013 at 23:41
  • Do you know which generation of an i7 it is ? A specific model number would be helpful. Commented Dec 4, 2013 at 23:44
  • sysctl -n machdep.cpu.brand_string yields: Intel(R) Core(TM) i7-3615QM CPU @ 2.30GHz
    – Deesbek
    Commented Dec 4, 2013 at 23:53
  • Your error indicates you have pointed your mining program at an unsuitable source of work. Commented Dec 5, 2013 at 1:23

2 Answers 2


The following program will show you the OpenCL-capable devices on a given Macintosh:

// clang -framework OpenCL dumpcl.c -o dumpcl && ./dumpcl

# include <stdio.h>
# include <stdlib.h>
# include <OpenCL/opencl.h>

int main(int argc, char* const argv[]) {
    cl_uint num_devices, i;
    clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, 0, NULL, &num_devices);

    cl_device_id* devices = calloc(sizeof(cl_device_id), num_devices);
    clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, num_devices, devices, NULL);

    char buf[128];
    for (i = 0; i < num_devices; i++) {
        clGetDeviceInfo(devices[i], CL_DEVICE_NAME, 128, buf, NULL);
        fprintf(stdout, "Device %s supports ", buf);

        clGetDeviceInfo(devices[i], CL_DEVICE_VERSION, 128, buf, NULL);
        fprintf(stdout, "%s\n", buf);


If it fails to show you your GPU then its a driver issue.If it succeeds then its some kind of a configuration error.


Upgrade to OS X Mavericks and it should work. It's a driver issue.

At least on my Macbook, after I upgraded to Mavericks I can mine on both the GeForce and the Intel HD 4000. Not that it makes sense to do so. ASICs have taken over, and even before that AMD was the GPU for mining.

  • I have upgraded to OS X Maverics and it has made no difference.
    – Deesbek
    Commented Dec 18, 2013 at 16:01
  • 1
    Mine litecoins with GPU. @Deesbek Commented Jan 7, 2014 at 2:09
  • @Prof.Falken thanks for the tip, I have friends who do that and Dogiecoin as well but I specifically needed to compare performance changes over time with GPU.
    – Deesbek
    Commented Jan 8, 2014 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.