2

Using Win7 64 bit I'm trying to get bitcoind (v0.8.5) to work.

Bitcoin.conf has the following content (in the %appdata%\bitcoin dir): rpcuser=12345 rpcpassword=12345

I run using command line: bitcoind -rpcpassword=12345

I then use the NIRSOFT app cports-x64 which shows list of open TCP/IP and UDP ports on computer. Bitcoind is in the list but only with port 8883.

Why is the RPC connection not working such that port 8882 (default RPC port) is open and mapped to 127.0.0.1?

1

You need to be running bitcoind with the -server option set as well as -rpcuser and -rpcpass. These can alternatively be set as lines in your bitcoin.conf. The RPC port will only be open on 8332 if all three of these options are correctly set.

  • bitcoind -server -rpcuser=USER_NAME -rpcpassword=PASSWORD with bitcoin.conf : rpcuser=USER_NAME rpcpassword=PASSWORD rpcallowip=* still no open port on 8332! – Wizard Of Ozzie Dec 6 '13 at 13:17
  • -printtoconsole and check the output. – Anonymous Dec 6 '13 at 13:21
1

QT's RPC API is set to listen by default to TCP port 8332.

Since you have specified the rpcuser and rpcpassword parameters in the bitcoin.conf file you don't need to explicitly specify them upon your call.

In a Command Prompt, run: bitcoind.exe -daemon -debugnet -printtoconsole and then open a new Command Prompt and type: netstat -a, once the RPC API is listening for connections you should see this: TCP 127.0.0.1:8332 myHostName:0 LISTENING

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.