1

For some reason, the daemon doesn't accept commands neither RPC, nor command-line. I'm running the prebuild 64 version of the bitcoind. It already downloaded all blocks etc and as is happyly running in the background, however it doesn't allow any commands to be sent. For example:

./bitcoind getinfo
error: couldn't connect to server

I tried with a config file having only the rpc user and pass, then I extended it with different params, and of course have restarted the daemon each time. Still - no luck.

The debug.log is not telling anything either. It just dumps the normal intensive communication, like…

 2013-12-07 22:01:40 received getdata for: tx  
 593f4528895f75bcd3df12fb09eedb7e5e6659a7a8a999d7e127eb131afde417)

but no trace from my attempts to call a simple command.

I tried to google the problem without luck.

1

In bitcoin.conf, make sure you have the following lines:

rpcuser=your-userid
rpcpassword=your-password
server=1
  • Hi. My current confi file looks like this: rpcuser=xxxxxxxxxxxxxx rpcpassword=yyyyyyyyyyyyyyy rpcallowip=127.0.0.1 rpcport=8332 rpcthreads=10 server=1 I started only with the first two lines, and then trying to fix it, added the remaining onese. But without luck. – Dimo Dec 7 '13 at 22:19
  • That should work. The only thing I can think of is your bitcoin.conf is not in the correct directory. It should be in the bitcoin data directory (this directory contains wallet.dat as well as the blocks and chainstate subdirectories). – ScripterRon Dec 7 '13 at 22:25
  • It uses this config file for sure. If I rename the file and restart the daemon, it throws an error. E.g. ` mv bitcoin.conf xxx.bitcoin.conf kill ####### ./bitcoind -daemon Bitcoin server starting Error: To use the "-daemon" option, you must set a pcpassword in the configuration file: /home/thebitco/.bitcoin/bitcoin.conf It is recommended you use the following random password: ....` – Dimo Dec 7 '13 at 22:32
  • Sorry for the bad formatting of the above, I still haven't learned how to put new lines and format code. – Dimo Dec 7 '13 at 22:34
  • Have you tried issuing netstat to see if bitcoind is listening for connections on port 8332? If it is, then I don't have any other suggestions. – ScripterRon Dec 7 '13 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.