0

raw hex:

0100000001390210797248b4f5a4a6c0fbcbde14a3ea132bdbfedb07aea35bff5cfc0766b1000000008a4730450220035db00b2bed0e4e97b92b9ee3610587110041c0e71f99b4563fe990d1a5a2b0022100ded70700477d36e7867dfb11842e86ef95e06e5fe910f4334730195493b362da41041862f45bcd7f2a0a8b2f1d24effdcede809ba4f46a78e5baac43ae0c0f6c651ceb02db5a9527ca9e722a4aca51284d6ee36408625b3463c68abfe3b5740aa42cffffffff0140420f00000000001976a914bee3bbfdad113a061739375edcfe6a908c096c7088ac00000000

I got this handcrafted tx from somewhere. I want to know why it is not being accepted. From sendrawtransaction in litecoin-qt, I get TX rejected (code -22)

EDIT: I missed a zero in the beginning. Fixed it

Here is what I get using decoderawtransaction

{
"txid" : "a3de612bfa175d4c688648e205644305561f7d2cd96ae6a4ad23cabac4e3b887",
"version" : 1,
"locktime" : 0,
"vin" : [
{
"txid" : "b16607fc5cff5ba3ae07dbfedb2b13eaa314decbfbc0a6a4f5b4487279100239",
"vout" : 0,
"scriptSig" : {
"asm" : "30450220035db00b2bed0e4e97b92b9ee3610587110041c0e71f99b4563fe990d1a5a2b0022100ded70700477d36e7867dfb11842e86ef95e06e5fe910f4334730195493b362da 041862f45bcd7f2a0a8b2f1d24effdcede809ba4f46a78e5baac43ae0c0f6c651ceb02db5a9527ca9e722a4aca51284d6ee36408625b3463c68abfe3b5740aa42c",
"hex" : "4730450220035db00b2bed0e4e97b92b9ee3610587110041c0e71f99b4563fe990d1a5a2b0022100ded70700477d36e7867dfb11842e86ef95e06e5fe910f4334730195493b362da41041862f45bcd7f2a0a8b2f1d24effdcede809ba4f46a78e5baac43ae0c0f6c651ceb02db5a9527ca9e722a4aca51284d6ee36408625b3463c68abfe3b5740aa42c"
},
"sequence" : 4294967295
}
],
"vout" : [
{
"value" : 0.01000000,
"n" : 0,
"scriptPubKey" : {
"asm" : "OP_DUP OP_HASH160 bee3bbfdad113a061739375edcfe6a908c096c70 OP_EQUALVERIFY OP_CHECKSIG",
"hex" : "76a914bee3bbfdad113a061739375edcfe6a908c096c7088ac",
"reqSigs" : 1,
"type" : "pubkeyhash",
"addresses" : [
"LcdHTvKV5PNBbhcHrd1h3QRNcJLsxkfUfd"
]
}
}
]
} 

EDIT: could be a problem with signatures. Can someone verify if the signatures are correct. I don't know enough about the litecoin protocol to do it myself.

  • Bitcoind can't decode that, so I've no idea how you managed to create it. – Anonymous Dec 9 '13 at 0:03
  • @Anonymous I made a typo in the transaction. I have fixed it. – Jus12 Dec 9 '13 at 0:09
1

It looks like these are freshly mined Litecoins that have not matured yet, you need to wait until they mature to spend them. Maturity refers to the number of confirmations that newly mined coins need to have. For Litecoin (and Bitcoin) this is 120 blocks.

(See a discussion related to this here: https://github.com/litecoin-project/litecoin/issues/26)

So you won't be able to spend these coins until those blocks get mined. But at the rate that Litecoin blocks get solved that would be around 4 hours, which means that same transaction might work now.

  • it does not seem to be that. Its been more than 12 hrs. I still get the same error. Also, on a block-explorer they dont seem to be fresh. – Jus12 Dec 9 '13 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.