4

I have two video cards. My main card is a nvidia 650ti and my second is an AMD R9 280x. My monitor is connected to the nvidia and I use it for normal things. I want to start cgminer only on my second card - the AMD R9 280x. I tried with cgminer -d1 but it says:

ADL found less devices than opencl!
There is possibly more than one display attached to a GPU
Use the gpu map feature to reliably map OpenCL to ADL
WARNING: Number of OpenCL and ADL devices did not match!
Hardware monitoring may NOT match up with devices!

I saw that there is this command:

--gpu-map <arg> - Map OpenCL to ADL device order manually, paired CSV (e.g. 1:0,2:1 maps OpenCL 1 to ADL 0, 2 to 1)

I have tried it but I don't know exactly what arguments to use and it does not work.

How can I use the command to start cgminer only for my second card?

2

to maps gpus i use this script:

cgminer -n option

Timeout /t 3600

Make it a .bat file and put it in the same folder as you cgminer, then you can tell witch gpu that is 0,1,2...

but you have to turn off power saving in windows to prevent you 280x form sleep, if you don't have a dummy-plug or an screen put to that device.

I used this guide for all start up information's: http://www.cryptobadger.com/build-your-own-litecoin-mining-rig/

Regards

EDIT: and when you use the -d command remember to have a space before the number.

0

You need a dummy plug on the card that isn't attached to a monitor. Had the same problem with my 7850 (it is dedicated miner). Use this guide:

Make a Dummy Plug

Then you can easily use the -d switch in your .bat file to choose which card you want cgminer to use. LSS: Windows doesn't see the card because there is no output, dummy plug tricks it into thinking it is in use when its not, drivers/opencl for the card are enabled windows side, cgminer can now operate properly.

0

Murch, not sure if you've figured this one out yet... I had the same problem for a week. cgminer -d would not provide info on 3 of my 4 GPUs. Also, ATICONFIG and AMDCONFIG would not provide temps and clock info for the 3 GPUs with --odgc or --odgt options.

I was able to fix it by reinstalling CGMINER-3.7.2 and adding the '--disable-adl' option. per the README file, this option overrides detection and disables building with adl. Also, don't use don't use 'make check' and 'make installcheck' to check the binaries before and after installation. For me, this caused the install to fail.

After using --disable-adl, ATICONFIG, AMDCONFIG (gives same info) and CGMINER -n all could sense the temps of my four GPUs. It took me a frustrating week to figure this out. Hope this helps...

By the way, I have the following: Mobo: Asrock 970 Extreme4 CPU: AMD Sempron GPUs: four XFX HD R7850s with 1GB Ram each RAM: Kingston DDR3 4GBs PSU: AZZA Titan 1000W 80+ Bronze OS: Debian 7.4.0 kfreebsd amd64 image

-1

Use the -d switch on cgminer, this allows you to specify which card(s) to use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.