I'd like to mine with my Intel HD Graphics 4000 (128SP 16C 350 MHz/1 GHz, 1.8 GB DDR3 1.6 GHz 64-bit, Integrated Graphics). I think it has support for OpenCL, as I ran benchmark software, and it said it has.

So I tried to use CGMiner on Windows in the single pool mode:

cgminer -o http://pool:port -u username -p password

But it said it could not find any devices:

 cgminer version 3.8.5 - Started: [2013-12-25 13:41:02]
 (5s):0.000 (avg):0.000h/s | A:0  R:0  HW:0  WU:0.0/m
 ST: 2  SS: 0  NB: 2  LW: 5  GF: 0  RF: 0
 Connected to dogepool.pw diff 16 with stratum as user Zignd.igor
 Block: f190f72c...  Diff:472  Started: [13:41:07]  Best share: 0
 [P]ool management [S]ettings [D]isplay options [Q]uit

 [2013-12-25 13:41:00] Started cgminer 3.8.5
 [2013-12-25 13:41:01] No devices detected!
 [2013-12-25 13:41:01] Waiting for USB hotplug devices or press q to quit
 [2013-12-25 13:41:01] Probing for an alive pool
 [2013-12-25 13:41:02] Pool 0 difficulty changed to 16
 [2013-12-25 13:41:02] Network diff set to 472
 [2013-12-25 13:41:07] Stratum from pool 0 detected new block

What should I do?

1 Answer 1


The latest cgminer no longer supports GPU mining -- it is now exclusively for ASIC mining.

Here is the old 3.7.2 version, which is the last one to support GPU: http://ck.kolivas.org/apps/cgminer/3.7/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.