I'am running Bitcoin-qt 0.8.6.1-beta on Qt 4.8.3 on windows 7 64.

below is my .conf content in %appdata%/bitcoin folder

rpcuser=bitcoinrpc
rpcpassword=ahything
rpcallowip=127.0.0.1
rpcallowip=192.168.*.*
rpcport=9332 
server=1
daemon=0
addnode=69.164.218.197

using curl 7.26.0 (i686-pc-mingw32), I run the following command:

curl --user 'bitcoinrpc' --data-binary '{"jsonrpc":"1.0","id":"curltext","method":"getinfo","params":[]}' -H 'content-type:text/plain;' http://127.0.0.1:8332

the pc ask for host password.

I have tried the .conf password and also the PC password (which is the one I log into my PC)

I always get error 401 (unauthorized) result.

Can anyone advice me where did I went wrong or how do I know which password it refer to?

TIA

Regards, KK Gian

You can also make a request by explicitly mentioning the username and password in the URI:

http://bitcoinrpc:ahything@127.0.0.1:8332/

Making your request to this address should be sufficient.

So, full command:

curl --data-binary '{"jsonrpc":"1.0","id":"curltext","method":"getblockchaininfo","params":[]}' -H 'content-type:text/plain;' http://bitcoinrpc:ahything@127.0.0.1:8332/
  • 2
    Keep in mind however that Steven Roose's suggestion won't work if there's an "@" in the password. Also depending on the connection location, the URL may be visible. It is certainly less secure and not suitable for remote system access. – user27425 Jul 15 '15 at 1:53

I got it to work by adding the password to the --user value, separated with ":". So the example becomes:

curl --user bitcoinrpc:xxxxxxxxxxxxxxx --data-binary '{"jsonrpc":"1.0","id":"curltext","method":"getinfo","params":[]}' -H 'content-type:text/plain;' http://127.0.0.1:8332

Where "xxxxxxxxxxxxxxx" is the rpcpassword stored in the .conf file.

  • Have you tried ? curl --user bitcoinrpc --password xxxxxxxxxxxxxxx --data-binary '{"jsonrpc":"1.0","id":"curltext","method":"getinfo","params":[]}' -H 'content-type:text/plain;' 127.0.0.1:8332 – szydan Dec 30 '15 at 2:38
  • curl: option --password: is unknown – emisilva Dec 19 '16 at 13:29

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.