4

I did a web search before posting, but none of the similar topics shed any light on my problem.

This is the command I'm using to start bitcoind:

./bin/32/bitcoind -datadir=/somedir -daemon

This is the contents of my bitcoin.conf, which is located in /somedir (of course):

server=1
rpcuser=some_user
rpcpassword=some_password
rpcport=8332
rpctimeout=60

Here are the results of netstat --ip -lpan | grep bitcoin

tcp        0      0 127.0.0.1:8332          0.0.0.0:*               LISTEN      24203/bitcoind  
tcp        0      0 0.0.0.0:8333            0.0.0.0:*               LISTEN      24203/bitcoind

Then I attempt to send a commend to the bitcoind using:

./bin/32/bitcoind -datadir=/somedir getinfo

Result

error: couldn't connect to server

I'm probably missing something simple and obvious, but what?

3

This happens usually when your server isn't yet fully loaded, i.e. the executable/binary is started, but is still busy processing (I think loading the wallet and a vital part of the block chain necessary for most basic RPC commands, although I'm not sure). This could take, depending on your wallet size and processing speed, from a few seconds to several minutes in general.

If that doesn't work please comment!

  • Just now, I tried waiting approx. 30 minutes after launching the server. Still the same result. – xtpu Jan 3 '14 at 19:13
  • Okay, well it was worth a try, but just to be sure: you don't happen to have several millions of Bitcoin addresses in your wallet? Also did this happen when you first run it or later? – Jori Jan 4 '14 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.