0

I am playing around with testnet and bitcoin rpc. I have send a test transaction of 1 bitcoin as can be seen here however in my wallet it still shows that the account has 5.2 bitcoin which is what it had before I sent the transaction. I have waited for 80 confirmations and still not change address has shown up and the bitcoins still seem to be in my wallet even though the blockchain clearly shows them as being sent. Can anyone explain what is going on I have never had this behavior when using any other wallet not with testnet which is why I am so confused by this.

  • Make sure the client has the block that has the transaction. – David Schwartz Jan 6 '14 at 9:39
  • I am up to date with the latest block listed on that site and when i run a getblock and look at the tx array I am able to see the transaction linked to above if that helps at all. Still showing at 5.2 bitcoins in my wallet though. – mschuett Jan 6 '14 at 9:49
  • You may want to stop the client and then restart it with -rescan. – David Schwartz Jan 6 '14 at 9:58
  • Ok, I am trying that out right now and will let you know how it goes. On top of that I sent another transaction with the same thing happening hopefully rescan will take care of both instances though. – mschuett Jan 6 '14 at 10:04
  • After letting the reindex run all night and looking again this morning it is still showing the same. Does anyone else have an idea what might be going on? the transactions are all clearly showing on blockexplorer still. Something I did notice is that my pool of pregenerated addresses does go down by one showing that a new address was generated for change after each one but when I dump out all addresses in my wallet none of them show up. – mschuett Jan 6 '14 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.