2

Before I install AMD APP SDK 2.8, I get this error from cgminer 3.7.2:

[2014-01-06 22:44:56] Error -1001: clGetPlatformsIDs failed (no OpenCL SDK installed?) [2014-01-06 22:44:56] clDevicesNum returned error, no GPUs usable
[2014-01-06 22:44:58] No devices detected!

After I install APP SDK 2.8, I get this window:

cgminer.exe has stopped working

My graphics card is ATI Radeon HD 545v. I have tried both Catalyst 13.4 and 12.10. The software versions are all 64 bit (except miners).

After installing SDK 2.8, guiminer exits when I run it. Before installation it shows a window:

No OpenCL devices were found.
If you only want to mine using CPU or CUDA, you can ignore this message.
If you want to mine on ATI graphics cards, you may need to install the ATI Stream SDK, or your GPU may not support OpenCL.

Question: How do I get to mining?

  • i had same problem and installed sdk and problem solved... – user13235 Feb 7 '14 at 20:16
1

Assuming you are using windows:

uninstall all AMD drivers

Do not install (uninstall) APP SDK.

download 3.11 beta version of catalyst drivers http://www.guru3d.com/files_get/amd_catalyst_13_11_beta_9_2_(13_250_18_november_7)_download,1.html

Make sure you're cgminer settings are modeset and try again. If you are never on modest cgminer settings, you may never know if your software/driver config will work.

1

Under Linux you will need to install:

  • AMD Drivers
  • AMD SDK
  • AMD ADL

I suggest using the following link as a guide, it has all the steps in detail.

Configure CGMiner 3.7.2 Under Linux

If you are using windows then you should be able to run it straight off.

0

Try running this in the command line if you haven't already.

setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
-1

Don't use the SDK. I don't think that it's necessary anymore.

Try uninstalling ALL AMD drivers (SDK and GPU), then reinstall just the Catalyst drivers. See if that helps.

  • It is still necessary for scyrpt on GPU's – hafnero Mar 9 '14 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.