0

I recently purchased a Nanofury ASIC unit. I tried running it on my Linux system, as I just let the computer sit and run. I couldn't get it to work on Linux, so I decided to give it a try on Windows = but I'm still getting the same problem.

I installed Zadig, found the device, and installed WinUSB to the Nanofury NF1 0.6 device. I could then see it in the Device Manager listed as:

'NanoFury NF1 0.6'

So the device is recognized by Windows, but when I run BFGminer on the -S all option for finding devices, I get this message:

'NO DEVICES FOUND: Press 'M' and '+' to add'

How do I get the NanoFury device to operate properly with Windows? I'd really hate to be out like $150 on something I can't even get to work.

I'm currently running BFGminer 3.9.0 - if that helps at all.

  • I'm currently running BFGminer 3.9.0 - if that helps at all. – user11750 Jan 7 '14 at 7:14
  • Im having the same problem I think zadig is making my Nano Fury Bitfury USB not to work , but need better description on how to get it to work please thx1 – user12380 Jan 18 '14 at 18:04
  • Having a similiar issue bitcoin.stackexchange.com/questions/23944/… – Phill Pafford Mar 25 '14 at 3:14
1

I was able to get my Nanofury working on Linux (rPi raspbian) and bfgminer 3.10.0 with a few permissions changes. You really have three options:

  1. Run bfgminer as root (undesireable)
  2. Add the user running bfgminer to the "root" group:

    usermod -G root -a miner

  3. Change group ownership of the usb device (you will need to determine which one is your Nanofury device):

    chgrp dialout /dev/bus/usb/001/006

Option 1 is the easiest, 3 is the most secure. I went with option 2 as a middle-ground.

I also reverted commit 8383e33 (git revert 8383e33) from the bfgminer git repository, which gets rid of the "reinitializing" warning, and gives me a better hashrate. I don't know the long-term effect of reverting this commit, though...

To start the miner, I use:

/path/to/bfgminer -S NFY:ALL --set-device NFY:osc6_bits=54

Once you have everything set up, you can write your settings (S, W, in bfgminer) and you can drop the -S NFY:ALL. You still need the --set-device, as far as I can tell, though.

Hope this helps!

|improve this answer|||||
0

BitFury based usb sticks are hard to get working. Have you installed the nfy specific drivers? I'm not sure if you have.

any more detail you can give is great

anyway, try appending the following line to your bfgminer command.

-S "NFY:ALL"

I will get some more documentation together from one of the guys who develops them and see what he knows about it. I remember we were having a hard time getting the nanofury sticks to work in ubuntu. In the end he ended up having to plug them in 1 by 1 i believe (but can't remember for sure)

|improve this answer|||||
  • When I first inserted the device, the Device Manager on my computer would not show it. I used Zadig to install the WinUSB driver to the device. At first, I couldn't find the device in the list - but I could find it after selecting 'List all Devices' in the options menu. It was listed as 'NanoFury NF1 0.6'. I installed the WinUSB driver, and could then see it in the Device Manager. BFGminer still doesn't recognize it. What other drivers could I need? – Damon Jan 7 '14 at 9:12
  • Also, the addition of `-S "NFY:ALL" had no affect on BFGminer. I would like to restate that I'm now trying to run it on Windows. I'd at least like to know if it's running properly on Windows before attempting to fix the issue on Linux. – Damon Jan 7 '14 at 9:16
0

Bitfury and Nanofury devices are completely different. You are describing a NanoFury. In windows NanoFury devices autodetect, and it works using the autodetected driver. It will NOT work using the BitFury driver as suggested above. What I did is I deleted the pushed in BitFur driver that I tried first using zadig. I then rebooted and reinserted the device and accepted the default windows driver. Then I used this command with BFGminer 3.9.0

bfgminer.exe -o 192.168.101.1:8332 -u YourUsername -p YouPassword --coinbase-addr YourBitcoinAddress -S all --set-device NFY:osc6_bits=54

After this it worked fine. I get 2.54 GH.

It is normal to see these errors with the NanoFury in Windows: NFY 0: Frequency drop over 50% detected, reinitialising.

I was getting these errors but still earning bitcoins. They come about every minute or so, unless you pool mine, then about every 15 minutes.

|improve this answer|||||
0

I had the same problem with the Nanofury. This is what works for me on Windows 7 Pro x64 using the Nanofury: I installed CP210xVCP, then I used the following command with bfgminer.

bfgminer-3.10.0-win64 -o yourpoolchoice -u yourusername_workername -p 123 -S all --set-device NFY0:osc6_bits=53

I created a shortcut for bfgminer in the same folder and put the above command into the shortcut target. Now, I can start it up by double clicking the shortcut, which is working fine with my nanofury.

|improve this answer|||||
0

Run "bfgminer --version" and see if you have the nanofury driver. If you don't you may need to build from the source (where the nanofury driver is included).

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.