0

I just wanted to install bitcoin-qt on another machine (all others are working fine) but I cannot seem to retrieve the block chain using bitcoin-qt 0.8.6-beta (as downloaded from http://sourceforge.net/projects/bitcoin/files/Bitcoin/bitcoin-0.8.6/bitcoin-0.8.6-win32-setup.exe/download).

I'm running bitcoin-qt (started as as administrator) on Windows 8 using a 3G data connection. After downloading a few thousand blocks the software keeps on quitting with the error "failed to read block". When I restart the software it fetches another thounsand blocks and quits with the same error soon.

Even a full reinstall (I additionally deleted the whole data directory in %APPDATA\Bitcoin) doesn's seem to help. Starting bitcoin-qt with "-reindex" didn't help either. I checked the hd-drive for errors but didn't find any.

What am I dong wrong?

  • As administrator?? Why do people do that? – Greg Hewgill Jan 11 '14 at 18:07
  • Usually I'm not doing this. I just wanted to prevent answers pointing out that rights problems could be the reason for this behaviour. – Sparafucile Jan 12 '14 at 9:23
0

Start bitcoin-qt in a new command prompt with the flag -reindex after you make sure your 3G provider doesn't block your downloads after a certain threshold.

  • I already tried to reindex. My provider doesn't block traffic (I can tell this as I'm working on the same connection meanwhile - without putting too much load on it). – Sparafucile Jan 11 '14 at 21:29
  • Since you have other computers working fine, one thing you could try is to copy the blocks' files from a working client to the one that throws that exception. You will have to delete in source and then copy the block files, which can be found under: en.bitcoin.it/wiki/Data_directory. You will need to rescan and wait until the new blocks get verified, just like as they had just been received by the network. – George Kimionis Jan 12 '14 at 2:30
  • OK, then I'll copy the block files from another machine when I return and get access to it. I just thought I set up bitcoin "quickly" (usually it takes about a night to be done) but in this case it didn't seem to work. Strange behaviour nevertheless... – Sparafucile Jan 12 '14 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.