2

Just before few hour I have setup bitcoin daemon on my ubuntu server and tested it with API and it is responding very well. Now I have installed litecoin daemon on the same server and used copied the same php files with a little sytax changes like change in username and password and port number but it is not responding to any API calls.

Content of litecoin.conf are :

server=1
daemon=1
rpcuser=my_username
rpcpassword=mypassword
rpcport=9332

Content of litecoin.php

<?php
include_once('jsonRPCClient.php');
$variable = $_GET['variable'];
$litecoin = new jsonRPCClient('http://my_user:my_password@127.0.0.1:9332/');
if($variable=='getnewaddress')
{
echo $litecoin->getnewaddress();
}
else if($variable=='getinfo')
{
print_r($litecoin->getinfo());
}
else
{
echo "hello";
}
?>

Any help of what I am doing wrong here ?

I was trying to figure out why php file is not throwing any error if there is any then I discovered that error_reporting in php.ini file is turned off after turning it on I got following error while executing litecoin.php on the browser :

Warning: fopen(http://...@myserveraddress.com:9332/): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /var/www/jsonRPCClient.php on line 132

Fatal error: Uncaught exception 'Exception' with message 'Unable to connect to http://myuser:mypassword@myserveraddress.com:9332/' in /var/www/jsonRPCClient.php:140 Stack trace: #0 /var/www/litecoin.php(12): jsonRPCClient->__call('getinfo', Array) #1 /var/www/litecoin.php(12): jsonRPCClient->getinfo() #2 {main} thrown in /var/www/jsonRPCClient.php on line 140

  • You are using HTTP, so you can use an IP packet sniffer to see what's going on. Is your connection accepted by the server? Does the server respond with any kind of HTTP response? – Greg Hewgill Jan 12 '14 at 22:15
  • @GregHewgill I have used the same file with bitcoin daemon with different parameters and its working fine. But litecoin is not working – Khan Shahrukh Jan 12 '14 at 22:23
  • Yes, you already said it wasn't working, but you haven't given any information that would allow anybody to guess a reason. I am suggesting a method for you to do some diagnostics to find out why it is not working. – Greg Hewgill Jan 12 '14 at 23:59
  • Try taking out the server=1 parameter from your litecoin.conf. If the rpcuser and rpcpassword values are literal in the above configuration (which I expect not) they should match with your $litecoin string (which they don't). Run ifconfig -a | grep 9332 to see if there is a listening port for 127.0.0.1 (0.0.0.0 is not enough). – George Kimionis Jan 13 '14 at 0:09
1

First add this line to litecoin.conf

rpcallowip=127.0.0.1

Then make sure you've added the litecoin command to your path

sudo cp litecoind /usr/bin/litecoind

and that your starting the litecoin daemon

litecoind -daemon

and test with

litecoind getinfo

if all that works then JSON RPC should work fine.

If none of that works try setting up the client by following this guide.

Also make sure your username and password are consistent across your PHP and litecoin.conf because they aren't in your example.

  • I have figured out that error_reporting was turned off in my php.ini file that is why it wasn't showing any error, now that I turned them on running litecoin.php on my server shows following error: – Khan Shahrukh Jan 13 '14 at 11:20
0

Sometimes this error is thrown because passing too many characters as rpcuser or rpcpassword in the config file I have sorted out this issue with reducing the length of the rpcuser and password and removing special characters

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.