2

I'm trying to download the block chain and synchronize with the network (using Bitcoin-qt 0.8.6). I have a 2 year old wallet.dat file with a fractions worth of unconfirmed bitcoins.

After over a day downloading the blocks folder has stopped increasing in size and is at 13.4GB.

In the debug.log file the following messages are repeatedly shown.

stored orphan tx 8d724a...ad48cfb140 (mapsz 10001)
mapOrphan overflow, removed 1 tx

It will then add another orphan transaction and then remove another one from the pool. The pool stays at 1001.

Should this be happening?

The message in the client says it has processed 0 of 280295 (estimated) blocks of history and that I am 162 weeks behind.

  • 1
    Just as a check: what version of Bitcoin-qt are you using? – Nate Eldredge Jan 15 '14 at 13:59
  • 1
    I'm using the latest version, which is currently 0.8.6. I've edited the question to clarify this. – Richard Jan 16 '14 at 9:59
0
+50

First of all, backup your wallet in a couple of places...

If you are in linux, move your ~/.bitcoin to ~/.bitcoin_old, once you've done that start bitcoin-qt, wait another day for the whole blockchain to download. This time it should be working OK. Replace the wallet in ~/.bitcoin with your wallet in ~/.bitcoin_old and resync.

Remember to have your wallet.dat saved before you do anything (I would have 2 or 3 copies in different places (usb, external HD, etc ...)

  • I'm using Windows. Should I see the number of blocks processed increase as it downloads the block chain. Tried this a few times now and it always stays at 0 processed. Delete blockchain and start again seems to be the standard 'turn it off and turn it back on' response and I'd like to know if it's working in less than a day. – Richard Jan 17 '14 at 14:11
  • As I stated, I would rather recreate the whole thing, not just the blockchain, I don't know what is the bitcoin folder in windows, but is should be something similar. Anyway, you should see the blocks increasing, it shouldn't stay in 0. Do you have any connections to the Bitcoin network? I think it is the rightmost icon in the bottom right of the window. If you don't, check if your Bitcoin ports are reachable from the Internet. – YoMismo Jan 20 '14 at 7:41
  • I had 20+ connections. I could tell it downloaded the full blockchain from the file size, but the number of processed blocks always stayed at zero in the UI. – Richard Jan 20 '14 at 10:25
  • Did you recreated it from scratch? I had corruption problems and the like, once I erased the blockchain and downloaded it again but the process hang on a certain block. All my probles where solved when I removed the whole directory and started from scratch. – YoMismo Jan 20 '14 at 10:40
  • I just deleted everything in C:\Users\Me\AppData\Roaming\Bitcoin except wallet.dat then started up BitCoin-qt. Blocks started to be processed straight away. I'm still 136 weeks behind, but my BitCoin are confirmed and it's obviously not stuck like before. – Richard Jan 22 '14 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.