1

Running bfgminer and notice that it is not submitting any shares to the p2pool. Mining a scrypt based crypto currency (Dogecoin). Noticed the same behavior when trying to mine litecoin.

However, while it seems to do work on my laptop (OS X 10.9.1), no shares actually get submitted to the pool. What can I do to fix this and get bfgminer to start submitting shares. Any help is appreciated.

I am running using this command.

bfgminer -k diablo --scrypt -o stratum+tcp://pool.shitpost.asia:1917 -u DKm9ayrnN1fAbikyRiqDMsdax4uizCpjZp -p anything -I 12 -S opencl:auto

Attached is a screenshot.

enter image description here

Also when I exit the program I get some additional information.

Summary of runtime statistics:

[2014-01-16 06:57:53] Started at [2014-01-16 06:48:44]
[2014-01-16 06:57:53] Pool: stratum+tcp://pool.shitpost.asia:1917
[2014-01-16 06:57:53] Runtime: 0 hrs : 9 mins : 9 secs
[2014-01-16 06:57:53] Average hashrate: 7.0 Megahash/s
[2014-01-16 06:57:53] Solved blocks: 0
[2014-01-16 06:57:53] Best share difficulty: 0
[2014-01-16 06:57:53] Share submissions: 0
[2014-01-16 06:57:53] Accepted shares: 0
[2014-01-16 06:57:53] Rejected shares: 0 + 0 stale (nan%)
[2014-01-16 06:57:53] Accepted difficulty shares: 0
[2014-01-16 06:57:53] Rejected difficulty shares: 0
[2014-01-16 06:57:53] Hardware errors: 0
[2014-01-16 06:57:53] Network transfer: 1.80 / 0.01 MB ( 3.3 / 0.0 kB/s)
[2014-01-16 06:57:53] Efficiency (accepted shares * difficulty / 2 KB): 0.00
[2014-01-16 06:57:53] Utility (accepted shares / min): 0.00/min

[2014-01-16 06:57:53] Unable to get work from server occasions: 0
[2014-01-16 06:57:53] Work items generated locally: 350
[2014-01-16 06:57:53] Submitting work remotely delay occasions: 0
[2014-01-16 06:57:53] New blocks detected on network: 13

[2014-01-16 06:57:53] Summary of per device statistics:

[2014-01-16 06:57:53] OCL0 | 5s: 6.67 avg: 6.87 u: 0.00 Mh/s | A:0 R:0+0(none) HW:0/none
[2014-01-16 06:57:53] OCL1 | 5s: 96.0 avg:107.7 u: 0.0 kh/s | A:0 R:0+0(none) HW:0/none
[2014-01-16 06:57:53]

  • I just figured out using -k diablo should be done only for mining sha256. If you use that has an option the kernel is set to diablo instead of scrypt. Taking out -k diablo and leaving --scrypt , I see my shares are being accepted. – user12297 Jan 16 '14 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.