1

Running Ubuntu 13.10. When I hook up the card to a monitor through HDMI, cgminer detects the card. When I unplug the HDMI cable from the monitor, the system throws a blank screen. I can ssh in from another computer, but when I run cgminer, cgminer tells me that the card isn't detected:

  • "clDevicesNum returned error, no GPUs usable"
  • "0 GPU devices max detected"

From various online forums, people have stated that dummy plugs won't work on the R9 290x because this card has only digital inputs (AMD got rid of analog), so the resistor trick won't work here even with DVI-VGA passive adapters.

Furthermore, people have said that with newer cards like mine, dummy plugs aren't necessary.

The only difference I see is that I'm using ubuntu while the people in the forums were using Windows 7 or 8. However, I'm using Catalyst 13.12, so I should be good?

What am I doing wrong? Can someone help me?

1

I had the same issue with my R290 cards and was able to have them work after initialiazing xinit:

Create an xinit file:

sudo vi /etc/init.d/xinit

Put inside:

#!/bin/bash
# standard functions library
. /lib/lsb/init-functions
# Start the xinit
start() {
        # Start xinit on background and redirect stdout and stderr to log file
        echo "Starting xinit"
        xinit &> /var/log/xinit.log &
}
# Restart the xinit
stop() {
        echo "Stopping xinit"
        killall xinit
}
### main logic ###
case "$1" in
  start)
        start
        ;;
  stop)
        stop
        ;;
  status)
        status xinit
        ;;
  restart|reload|condrestart)
        stop
        start
        ;;
  *)
        echo $"Usage: $0 {start|stop|restart|reload|status}"
        exit 1
esac
exit 0
# end of file

ESC :wq ==> to save and quit vi editor

Then make this script executable and set it up for automatic startup.

sudo chmod +x /etc/init.d/xinit 
sudo update-rc.d xinit defaults 90

export DISPLAY=:0
echo export DISPLAY=:0 >> ~/.bashrc

sudo reboot

It worked for me!

BTC: 1KsRn32jBwA21fLyVMdVWdGLxAa3vo82Zy

LTC: LQC2cfKFNri8AHeME6QQqVeB4BD6tQEdDE

P.S. xinit setup taken from http://infi.wikidot.com/blog:1

  • 1
    Are you listing your addresses for btc and ltc hoping for donations? – Tom Stickel Jan 19 '14 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.