1

I downloaded Bitcoin-QT for Windows 7 into:

MYUSERNAME/Downloads/bitcoin-0.8.6-win32/bitcoin-0.8.6-win32

I want to run Bitcoin in testnet mode, so I created bitcoin.conf with only the following content:

testnet=1

I put copies of bitcoin.conf into the following folders:

MYUSERNAME/Downloads/bitcoin-0.8.6-win32/bitcoin-0.8.6-win32
User/MYUSERNAME/AppData/Roaming/Bitcoin

When I double clicked on the Bitcoin-QT icon to execute the following, Bitcoin-QT starts up but it does not appear to be in testnet mode.

MYUSERNAME/Downloads/bitcoin-0.8.6-win32/bitcoin-0.8.6-win32/bitcoin-qt.exe

Can anyone tell me why it does not seem to go into testnet mode?

I went to Start > cmd to get the DOS prompt. I entered the following and it worked:

C:\User\MYUSERNAME\Downloads\bitcoin-0.8.-win32\bitcoin-0.8.6-win32>bitcoin-qt.exe -testnet

Bitcoin-QT launches in testnet mode. However, it is not synchronizing with the network. At the bottom, it shows "No block source available...155 weeks behind".

I tried adding the following to bitcoin.conf and restarted bitcoin-qt.exe -testnet but it didn't make any difference.

addnode=1.2.3.4
checklevel=2

After a few hours, it still shows "No block source available...155 weeks behind". How do I get this to synchronize?

9
  • It can take more than hour to synchronize. Does "X weeks behind" change?
    – John T
    Jan 26 '14 at 3:53
  • It has been a few hours now and it still shows "No block source available...155 weeks behind".
    – JLP
    Jan 26 '14 at 17:18
  • For your first question, I would suspect that you haven't put your bitcoin.conf in the place where the Bitcoin client is looking for it. The correct folder should already contain files named like debug.log, peers.dat, and several others. Jan 26 '14 at 19:03
  • @NateEldredge I have bitcoin.conf in the User/MYUSERNAME/AppData/Roaming/Bitcoin folder. This folder has the peers.dat, wallet.dat, db and debug files as well. There is no debug.log file. Do you have any ideas on why it is showing "No block source available"?
    – JLP
    Jan 27 '14 at 4:21
  • Typically this means it is not able to connect to any peers on the Internet. One possible cause is bad proxy settings, which is why I wondered if it was using a bitcoin.conf different from yours. Otherwise, could there be firewall settings or something similar preventing the application from communicating with the Internet? Jan 27 '14 at 5:05
0

I got it to work by adding

[test]  
addnode=104.237.131.138  
addnode=151.80.205.132  
addnode=192.155.82.123  
addnode=74.220.255.190  

to the config file.

The reason is your wallet needs to connect to nodes to connect to the blockchain. Usually it comes with all the nodes required to connect, but sometimes the devs failed to include the nodes or released a new node list after an update (try looking in the bitcointalk page or the official website listed by the coin developers), so you have to add them manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.