0

I've created a litecoin-qt server with the following configuration:

{
"pools" : [
        {
                "url" : "http://192.168.10.5:9332",
                "user" : "something",
                "pass" : "somethingelse"
        }
]
,
"auto-fan" : true,
"temp-cutoff" : "95",
"temp-overheat" : "85", 
"scrypt" : true
}

I'm able to connect to it from at least 3 different machines on the network, plus one connection from itself (I'm having cgminer run on the server).

However, I'm unable to connect from any other machines - it flashes the following:

[2014-02-04 21:47:03] Pool: 0  URL: http://192.168.10.5:9332  User: something Password: somethingelse
 [2014-02-04 21:47:03] Press any key to exit, or cgminer will try again in 15s.
 [2014-02-04 21:48:03] HTTP request failed: Operation timed out after 60000 milliseconds with 0 out of -1 bytes received
 [2014-02-04 21:48:03] Failed to connect in json_rpc_call
 [2014-02-04 21:48:03] Succeeded delayed connect
 [2014-02-04 21:49:03] Timed out waiting for response in initiate_stratum
 [2014-02-04 21:49:03] Initiate stratum failed
 [2014-02-04 21:49:03] Closing socket for stratum pool 0
 [2014-02-04 21:49:03] FAILED to retrieve work from pool 0 http://192.168.10.5:9332
 [2014-02-04 21:49:03] Pool 0 slow/down or URL or credentials invalid

And ends with:

 [2014-02-04 21:40:48] Timed out waiting for data on socket_full
 [2014-02-04 21:40:48] Initiate stratum failed
 [2014-02-04 21:40:48] Closing socket for stratum pool 0
 [2014-02-04 21:40:48] FAILED to retrieve work from pool 0 http://192.168.10.5:9332
 [2014-02-04 21:40:48] Pool 0 slow/down or URL or credentials invalid

The datetimes are slightly off since I fetched these logs in different run instances.

  • Are those other machines outside of your network and getting blocked by a firewall or port rules? – John T Feb 4 '14 at 21:25
  • Hi Jacob - no, they're all on the same wifi and the other machines can ping the .10.5 one. This is all on Windows - am I running into a connection limitation? – siliconpi Feb 5 '14 at 1:57
  • Bitcoind by default accepts up to 8 connections. Have you tried pinging the ip address from the trouble computers? – John T Feb 5 '14 at 1:58
  • Yup - did that again before typing the above - am able to receive responses. Still seeing the above message (second quoted block) - note, this isn't a stratum pool. – siliconpi Feb 5 '14 at 2:02
  • It may be a network issue most likely. Are you using the correct ip address, port, and password for sure? The following line suggests that no communication is even established, so it's not a problem with configuration of pool. HTTP request failed: Operation timed out after 60000 milliseconds with 0 out of -1 bytes received – John T Feb 5 '14 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.