0

I'm specifically litecoin/scrypt mining at Multipool.us, but the web interface there is only showing about 20khash, when I obviously should be getting much more. I am using a HD 5870 (GPU 0) and HD 7850 (GPU 1) on Linux, specifically Ubuntu Server 13.10. Are my GPUs working correctly, and if not, what should I change? Thanks.

 cgminer version 3.7.2 - Started: [2014-02-04 17:14:29]
--------------------------------------------------------------------------------
 (5s):606.0K (avg):589.6Kh/s | A:1792  R:0  HW:37264  WU:16.3/m
 ST: 5  SS: 0  NB: 84  LW: 1051  GF: 23  RF: 0
 Connected to eu2.multipool.us diff 256 with stratum as user XXX
 Block: 7880a600...  Diff:1.1K  Started: [18:26:10]  Best share: 8.16K
--------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  76.0C 2843RPM | 303.1K/295.0Kh/s | A: 768 R:0 HW:18955 WU: 4.0/m I:16
 GPU 1:  76.0C 1688RPM | 303.1K/295.0Kh/s | A:1024 R:0 HW:18334 WU:12.3/m I:16
--------------------------------------------------------------------------------

 [2014-02-04 18:13:02] Stratum from pool 0 detected new block
 [2014-02-04 18:13:27] Stratum from pool 0 detected new block
 [2014-02-04 18:14:27] Stratum connection to pool 0 interrupted
 [2014-02-04 18:14:28] Pool 0 difficulty changed to 512
 [2014-02-04 18:14:28] Pool 0 difficulty changed to 256
 [2014-02-04 18:14:43] Stratum from pool 0 detected new block
 [2014-02-04 18:15:35] Stratum from pool 0 detected new block
 [2014-02-04 18:15:48] Stratum from pool 0 detected new block
 [2014-02-04 18:16:13] Stratum from pool 0 detected new block
 [2014-02-04 18:16:39] Stratum from pool 0 detected new block
 [2014-02-04 18:16:50] Stratum from pool 0 detected new block
 [2014-02-04 18:17:10] Stratum from pool 0 detected new block
 [2014-02-04 18:17:49] Stratum from pool 0 detected new block
 [2014-02-04 18:18:45] Accepted 080863ba Diff 8.16K/256 GPU 1
 [2014-02-04 18:19:49] Stratum connection to pool 0 interrupted
 [2014-02-04 18:19:50] Pool 0 difficulty changed to 512
 [2014-02-04 18:19:50] Pool 0 difficulty changed to 256
 [2014-02-04 18:20:24] Stratum from pool 0 detected new block
 [2014-02-04 18:21:08] Stratum from pool 0 detected new block
 [2014-02-04 18:22:09] Stratum connection to pool 0 interrupted
 [2014-02-04 18:22:09] Pool 0 difficulty changed to 512
 [2014-02-04 18:22:09] Pool 0 difficulty changed to 256
 [2014-02-04 18:22:19] Stratum from pool 0 detected new block
 [2014-02-04 18:23:02] Stratum from pool 0 detected new block
 [2014-02-04 18:23:12] Stratum from pool 0 detected new block
 [2014-02-04 18:23:25] Stratum from pool 0 detected new block
 [2014-02-04 18:23:55] Stratum from pool 0 detected new block
 [2014-02-04 18:24:18] Stratum from pool 0 detected new block
 [2014-02-04 18:24:30] Stratum from pool 0 detected new block
 [2014-02-04 18:25:32] Stratum from pool 0 detected new block
 [2014-02-04 18:25:41] Stratum from pool 0 detected new block
 [2014-02-04 18:25:55] Stratum from pool 0 detected new block
 [2014-02-04 18:26:10] Stratum from pool 0 detected new block
  • The logs you pasted are suggesting you are mining at an average of 589.6Kh/s on the third line. It also adds up on the two GPU lines. – John T Feb 4 '14 at 23:35
1

Right next to HW is the number of hardware errors you are seeing. This is an indicator that your intensity is set too high. Decrease your intensity until you stop seeing hardware errors. I usually use this link as a starting point for my configurations: https://litecoin.info/Mining_hardware_comparison

1

Take a look at the following link, there is a FAQ near the end which answers this question specifically.

http://www.kaostheory.net

To summarize it up, you need to make sure there isn't any hardware (HW) errors. This means that your configuration is not set correctly.

Another thing to look out for is work units (WU). This specifies how many hashes are actually being sent to the pool (after the rejected (R) and hardware errors).

You should expect that the WU is 90% of your raw hash rate. This tells you that you have a good and stable configuration.

Good luck!

0

There is room for a lot of improvement with these cards. You should reduce Intensity, and tweak the thread-concurrency.

First delete all .bin files in the cgminer folder, then run it only with -n parameter. This will generate a bin file containing a number with the detected threads available.

Now run cgminer with thread-concurrency set to the number found in the bin filename and intensity at 13 for example.

After that if the hashrate is still very low, add to the thread-concurrency and relaunch. You can also try to overclock the gpu and memory directly with cgminer.

cgminer --help will show you available parameters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.