I understand that GPU might have less accurate results of real numbers because speed/performance is the target. But I don't understand why it also occurred in integer numbers.

Taking mining algorithm, scrypt hashing, for example, there are almost integer operations in SHA-256 or PBKDF, such as unsigned integer rotate, shift, add, xor, and bit-select operators. However, it does generate so many false-positive nonces. Everyone can invoke cgminer with arguments -T -D --verbose to see the detail logs. However, cgminer will verify the result via CPU routine again before sending it to mining pool because too many invalid share cgminer will be banned from the pool. Not everyone knows their GPU generates so many false-positive shares because the default log message does not show this.

So, I don't understand that. Is the problem in GPU or in the scrypt OpenCL code?

  • Interesting. Have you checked on other hardware? GPU failure? My CPU got super hot when I had all threads test hashing.
    – user5107
    Feb 10, 2014 at 15:02
  • 1
    No. You can invoke cgminer with the argument '-T -D --verbose' to see what is going on. I believe hat's not GPU failure because it can continue producing the correct nonce, and the mining pool see the right hash-rate as well. Of course CPU is super hot because CPU needs to feed data to GPU and keeps verifying all results generated from GPU
    – jclin
    Feb 10, 2014 at 15:09
  • 1
    I definitely see more errors when I push my cards too close to their limits. I assume it has something to do with hardware errors.
    – Chris S
    Feb 10, 2014 at 15:17
  • 1
    The issue also can be reproduced when you did not push your cards to their limits, for example, lower intensity. Even you set with proper or lower GPU engine/memory clock rate (I did not overclock the GPU). And this is not HW error in cgminer because you can see many false-positive but with 0 HW errors when you run with -T -D --verbose.
    – jclin
    Feb 10, 2014 at 15:27
  • I believe this belongs more in Con Kolivas' page as a bug request than here. Anyway, your testing looks interesting - have you tried using an über low intensity? Is this anything to do with the "hardware errors" measure that cgminer does show, or is it something different?
    – Joe Pineda
    Feb 10, 2014 at 16:48

1 Answer 1


It's likely your intensity is too high. Usually higher intensity or other settings may look good with higher hashing power, but in truth results in a lot of false positives.

Playing around with the settings till you get the sweet spot is the best practice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.