1

I want to make some test on testnet using the API and I would like to fetch datas from a remote computer. The client is on raspberry which has an internal IP,than I have a dyndns address which pings my router on a given port(3400) -> from router I redirect the request to raspberry PI's IP with clients port for API calls(192.168.178.40:8332) and I have this in my

rpcallowip=192.168.178.40

but I get 403 status code

1

It isnt clear what you're doing, and I get the impression that you dont speak english natively, so I doubt we're going to get a better explanation of what you're trying to do. Given your question I can only assume your RaspberryPi's IP is 192.168.178.40, it is running bitcoind, and your trying to access the API on it from a computer somewhere on the internet (because you mention dyn-dns), and that there is a router in front of the RaspberryPi performing NAT. If you want any computer on the internet to be able to access the API

rpcallowip=0.0.0.0/0

or if you only want a single computer on the internet with a static IP to be able to access it, then you'd put in the IP address of that computer rather than the RaspberryPi's IP address.

If I got it wrong, try rephrasing your question, because as I said, we don't know how your network is configured.

  • yes I do not speak english natively but I think is quite obvious what was my target what in the mean time I fixed – fefe Jun 19 '14 at 8:22
  • no, it isnt obvious to anyone here but you – Matt Jun 19 '14 at 11:09
1
  1. First find your computer ip address.
  2. Now copy it and go to your remote desktop where your qt wallet is run
  3. Open qt wallet config file and set rpcallowip = PASTE YOUR IP ADDRESS
  4. Save it and restart your qt wallet
  5. Now close your remote desktop and come back to your pc.
  6. set bitcoin qt url as per your remote desktop IP address for eg http://YOUR.REMOTE.DESKTOP.IP:8332
  7. Run any method of bitcoin rpc like getnewaddress and your address is created on remote desktop where your bitcoin qt wallet host.
0

HTTP 403 is "forbidden". You need to set rpcallowip to allow incoming connections, and also the ssl options to prevent people from sniffing your password and walking away with your wallet.

Running a full Bitcoin node on a Raspberry Pi is foolish anyway, it will never keep up properly with the blockchain and cause you a variety of speed and IO related issues. The SD card will likely die within a few days due to the heavy cycles.

  • as you see I was setting rpcallowip this is the testnet networ so they can do what they want – fefe Feb 18 '14 at 21:34
0

If I'm interpreting your question correctly, I think you are setting rpcallowip incorrectly. It should be set to the IP address of the remote host, not the computer running Bitcoin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.