I'm having issues starting dogecoind after compiling in ubuntu 12.04 x64 running in VirtualBox on win 7 ultimate x64

here's what i've tried from inside dogecoin/src after make -f makefile.unix:

sudo su
./dogecoind -server -listen -daemon -rpcuser=dogerpc -rpcpassword=dogerpcpw -rpctimeout=30 -rpcport=8334 -rpcallowip=192.168.1.* -rpcallowip= -testnet

and i get:

Error: To use the "-server" option, you must set a secure rpcpassword in the configuration file:

so i do:

cd ~/.dogecoin
emacs dogecoin.conf

i save the following parameters:


i even chmod 777 dogecoin.conf to be sure everyone on God's green earth could access it so that wouldn't be a problem, but still the same error when trying to start up dogecoind

would much appreciate any help/tips!

  • This is not Bitcoin related, and you shouldn't be running random daemons as root. It's likely a capitalization error, with this sort of crap it usually is case related.
    – user13413
    Feb 19, 2014 at 22:08
  • 1
    although SUPER helpful, i'm running a secure dev env so i can run as whatever user i seem fit. furthermore, the daemon is a derivative of the bitcoin daemon so the question is still relevant. not to mention that according to SO meta, bitcoin.se is for all cryptocurrency related qa. thanks for playing tho
    – Jon B
    Feb 19, 2014 at 22:11
  • "Secure dev environment" and "running every process as root" are incompatible statements, you have have one or the other. My comment is actually quite relevant, a lot of scamcoins have has issues with some systems being case sensitive and others not being.
    – user13413
    Feb 19, 2014 at 22:14
  • @goatse: According to community discussion questions about altcoins are on topic.
    – Murch
    Feb 23, 2014 at 9:11

5 Answers 5


I think the problem is with version 1.5 of dogecoin.I used rpcpassword=DLKKWE93203909238dkkKKeowxmIOw0232lsakwL02k

to solve the problem. Change the password to whatever you want, just use lowercase, upper case and numbers, it should fix the problem

  • thanks for the suggestion! i won't be able to try this til i get home for the night, but do you think my issue is that the password i'm trying is too short (not 43 chars) or that what i was using for a password that included an underscore?
    – Jon B
    Feb 25, 2014 at 18:56
  • @JonBest: Dogecoin checks for a weak password (here's the code: github.com/dogecoin/dogecoin/commit/…). It estimates the number of bits of entropy by taking the log base 2 of the number of unique characters, and multiplying that by the length of the password. If the number of entropy bits is less than 64, then the password is considered "weak" and is rejected. Feb 25, 2014 at 19:30
  • @JonBest yes, your issue is that rpcpassword. its supposed to be a long mix of upper case, lowercase and numbers. It was just added in a latter release of dogecoin 1.5 which included checkpoints and stronger rpcpassword for much security wow. lol, anyways, i was also confused by it when I compiled it, but I understood it after I tried long password. What greg said is exactly true. Feb 25, 2014 at 20:04
  • thanks for the specifics! makes sense now...can't wait to correct this this afternoon (;
    – Jon B
    Feb 26, 2014 at 0:20
  • wow! much thanks! i do a 42 character long [a-zA-Z0-9] password and it worked. thanks so much @GregHewgill and @ user2185284 !
    – Jon B
    Feb 26, 2014 at 5:04

It's unclear which version of dogecoind you are using. However, in the current 1.5 code on Github, there is a similar message:

if (mapArgs["-rpcuser"] == "" && mapArgs["-rpcpassword"] == "")
    throw runtime_error(strprintf(
        _("You must set rpcpassword=<password> in the configuration file:\n%s\n"
          "If the file does not exist, create it with owner-readable-only file permissions."),


This indicates that your attempt at working around the problem with chmod 777 would not have had the desired effect. Instead, try chmod 600 dogecoin.conf.

  • i tried chmod 600 and that didn't work either...even when i give the parameters in the CLI i get the same thing
    – Jon B
    Feb 20, 2014 at 7:10

Dogecoin does not use port number 8334 the port for dogecoin is 22555 and if the above mentioned is really your password please change it to something more strong

  • def not my real pw lol i'm gonna try what you and greg said shortly
    – Jon B
    Feb 20, 2014 at 4:09
  • changing the port didn't work
    – Jon B
    Feb 20, 2014 at 7:08
  • change your conf file with the follwoing server=1 daemon=1 rpcuser=yourusername rpcpassword=yourpassword after saving restart dogecoind Feb 21, 2014 at 10:14

Dogecoin is pretty much a vanilla Bitcoin client with a few tweaks. I noticed I got this same error if there were any syntax errors in my config file. In my case, I had a "parameter-value" instead of "parameter=value".


Your password is too short, make it longer and it should work.

  • that's not the real pw, but i did try a much longer password that didn't work either
    – Jon B
    Feb 20, 2014 at 7:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.