0

I imported all my private keys (including those of change addresses) to Andreas Schildbach's Bitcoin Wallet from bitcoin-qt and my balance is still zero. This disagrees with Blockchain, which clearly shows non-zero final balance. What is the reason and how can I fix it?

9
  • Can you explain in more detail what you did to import the keys? Do the corresponding addresses appear in the Android wallet's address book? Feb 20, 2014 at 7:09
  • listaddressgroupings -> dumpprivkey for every address that has non-zero balance
    – Michał B.
    Feb 20, 2014 at 11:29
  • Ok, that's how you exported them from bitcoin-qt, and sounds correct. How did you import them on the other side? Feb 20, 2014 at 14:26
  • I looked up how .key files are constructed and just pasted respective private keys. It was imported successfully into Android wallet. Maybe there is a more straightforward way? Tried pywallet -> multibit, but pywallet only outputs encrypted keys...
    – Michał B.
    Feb 20, 2014 at 15:54
  • So to confirm, the imported addresses do show up in the "Your addresses" tab of the address book? Have you tried the "Reset blockchain" option in the Settings menu? Feb 20, 2014 at 16:25

1 Answer 1

1

Probably you didn't set the wallets birthdate correctly. In any case usage like this is strictly discouraged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.