2

I have 3 R9 280x sapphires I use with sgminer

On almost every single pool, with or without --no-submit-stale, after about 5 min of hashing, my worker get's banned and hashing drops to zero. If I lower the intensity, I barely get 500mh/s if that. If I set it to 13, it runs normal, but I get banned?

sgminer -o stratum+tcp://neo.cryptcoins.net:3331 -u user.worker -p x -I 13 -D -P --no-submit-stale

How can I prevent from getting banned with a decent hash rate?

[18:58:33] RECVD: , "Worker is temporarily banned", null], "id": 666, "result":
  • Here's a mention of banning I found looking through the stratum-miner source code. Excessive sending of invalid shares or shares above indicated target (see Stratum mining docs for set_target()) may lead to temporary or permanent ban of user,worker or IP address.. Maybe your config settings are wrong? – John T Feb 21 '14 at 6:37
  • @Jacob Torba That sounds correct. But I have no idea where to begin looking. sgminer doesn't have a .conf :( – dooode Feb 21 '14 at 13:04
  • Look for error messages in output? – John T Feb 21 '14 at 19:29
  • @Jacob Torba Just this, and nothing else, in any log file. [18:58:33] RECVD: , "Worker is temporarily banned", null], "id": 666, "result": null} JSON decode failed(1): end of file expected near ',' – dooode Feb 22 '14 at 13:13
  • @dooode Post your issue here - github.com/veox/sgminer/issues?milestone=2&state=open – gotqn Mar 23 '14 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.