I just compiled dogecoin-qt using the original source, and edited it to generate new genesis block, because i want to create new coin for educational purpose. It is working just fine, and without an error, but whenever i try to crate a conf file in %appdata%\dogecoin\dogecoin.conf with this content

rpcuser=abc rpcpassword=abcd rpcport=22565 server=1 daemon=1 listen=1

It will say

"To use the -server options you must setup a secure rpcpassword in configuration file at xxxxx\Dogecoin\dogecoin.conf rpcuser=xx rpcpass=xxxxxxxxx

this an error that should only appear if i used server=1 in conf file, but dont provide rpcuser and pass. but i am already providing that.

I am looking for someones help to get me to understand what I am doing wrong. And sorry if this doesn't belong here.

  • 1
    If you're modifying the source code, then you're programming. Use your debugger and put a breakpoint on the message you get and find out how it got there. We can't really help you because we don't know what you have modified. Feb 24, 2014 at 17:21
  • @GregHewgill pastebin.com/YnBWT7L1 I ran dogecoin-qt with --debug from cmd, and saved this debug. Please have a look. I see that it says 2014-02-24 18:23:01 Bound to [::]:33465 2014-02-24 18:23:01 Bound to it should write, right? I did not modify code at all, other than changing the genesis block and modifying the total number of coins, coins per block etc. Feb 24, 2014 at 18:26
  • I don't see a problem with that. Address means it's listening on all interfaces, not just Feb 24, 2014 at 19:12
  • @GregHewgill could this be a reason that I mined genesis block by using testnet feature of the coin, then added the genesis block hash and merkle hash to the coin's source code, and compiled again. And that is why the coin has this problem? Because I have heard some problem with bitcoin where if you run bitcoin -testnet. you have to paste the bitcoin.conf to %appdata%\bitcoin\testnet\bitcoin.conf or %appdata%\bitcoin\testnet.conf could that be an issue? Feb 24, 2014 at 19:16
  • @GregHewgill thank you for the link of that thread. yes, i have the same issue with dogecoin-qt and dogecoind. on that thread, no one was able to help them out. Feb 25, 2014 at 4:32

1 Answer 1


I think the problem is with version 1.5 of dogecoin.I fixed it by using this long password.


to solve the problem. Change the password to whatever you want, just use lowercase, upper case and letters, it should fix the problem

Not the answer you're looking for? Browse other questions tagged or ask your own question.