0

I ran the Mavericks update today, putting me at 10.9.2 and now my Bitcoin-Qt stops responding after it notifies me that it is "verifying blocks". I am using it for ongoing research and am in a bad spot now. I realize I should have thought about the possible ramifications of running the update.

At any rate, is anyone able to get it to run? I've tried running it from the .dmg via the gui and via command line. I get the same results in both cases. As soon as it goes to verify blocks, it stops responding.

1

Yes, it's running on my system, which is a 5 year old Macbook Pro running 10.9.2. I have 4gb ram and a 2.4ghz Core 2 Duo.

I did have problems however trying to sync the blockchain initially. I had a partial blockchain that I had on another computer, which I copied over. Normally in this case the computer reindexes the block files on disk, figures out where it is, and then picks up downloading from the last point.

However, I got behaviour very similar to what you're describing. It would go to "verifying blocks" and stay that way for a very long time.

In the end I fixed it by deleting all of my previous blockchain (I deleted everything but wallet.dat), and then let the app download the blockchain from the beginning. It took about 4 days, but in the end it works as expected.

Didn't really test it out much, but I don't think I saw the same thing on my 20gb Mac Pro, so I think the MacBook was just too resource constrained.

Also, the new Bitcoin coming out, Bitcoin 0.90, is available as a 64 bit app for Mac OSX, so this will likely help. I'm running 0.90 on my Windows machine and it's fine. Haven't put it on the Mac yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.