0

I compiled Bitcoin, Dogecoin, and many other pow/pos cryptocurrencies without a problem. I usually compile daemon and then windows-qt wallet using qt 5.2.

But maxcoin and its clones like Helixcoin and galleoncoin always throw this particular error once I have compiled and run on windows 8. QT4.8.5

the procedure entry point memmove s could not be located in the dynamic link library msvcrt.dll

coin daemon compiles and runs without a problem. And I downloaded their pre compiled windows-qt wallets from official websites and they work fine.

this is my config for compilation

BOOST_LIB_SUFFIX=-mgw48-mt-s-1_50 
BOOST_INCLUDE_PATH=C:/boost-1.50.0-mgw
BOOST_LIB_PATH=C:/boost-1.50.0-mgw/stage/lib
BDB_INCLUDE_PATH=C:/db-4.8.30.NC-mgw/build_unix
BDB_LIB_PATH=C:/db-4.8.30.NC-mgw/build_unix
OPENSSL_INCLUDE_PATH=C:/openssl-1.0.1c-mgw/include
OPENSSL_LIB_PATH=C:/openssl-1.0.1c-mgw
MINIUPNPC_INCLUDE_PATH=C:/
MINIUPNPC_LIB_PATH=C:/miniupnpc-1.6-mgw
QT4.8.5

This is the source I am working on https://github.com/HelixCoin/

I have already looked through all of the files and I do not understand the cause of this error. And there is not much help on internet.

  • You might want to try updating msvcrt.dll, as it seems that your version is lacking a function that Maxcoin wants to use. – This came up in a websearch, but it is for WindowsXP: support.microsoft.com/kb/324762/en – Murch Mar 28 '14 at 9:07
  • @Murch Hi, I appreciate your comment. But those coins work fine which are pre compiled by devs. And can you tell me where do I obtain the msvcrt.dll which would be best for maxcoin? I cant find it anywhere. – user2185284 Mar 28 '14 at 9:11
  • The precompiled version probably includes the dependencies, which would be why it only occurs for the self-compiled. – Murch Mar 28 '14 at 9:13
  • Maybe this helps: tomshardware.co.uk/forum/68006-63-reinstall-msvcrt-library – Murch Mar 28 '14 at 9:17
  • oh, that makes sense. Do you know how to include the dll files in the new compilation. What I mean is there is nothing in the files that could give me an idea of how to include the missing dlls in the qmake or makefile on windows. Can you point me to the right direction. Thank you! Edit: let me check that out. – user2185284 Mar 28 '14 at 9:19
1

So I finally decided to give up trying to use qt 4.8.5 and helixcoin and galleoncoin github sources. And used qt 5.2.0 with slothcoin source from github. Which worked fine. And qt wallet started without a problem. Though I still dont understand why was qt 4.8.5 not including the msrvct.dll file. maybe that these libs were never included in qt 4.8.5? Seems to be compile fine on windows 8.1 and ubuntu 12.04 :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.