2

Been trying for the past few days but couldn't get it working, I already download the latest cryptopp library but its seems that maxcoin got some issue compiling

If I qmake "USE_UPNP=-" maxcoin-qt.pro then i make -f Makefile.Release

I will get the error below, I tried replace the content of ws2tcpip.h with winsock2.h and I get another error with getaddrinfo at netbase.cpp which most probably need ws2tcpip.h , for this scenario where I need ws2tcpip for netbase.cpp yet if I don't fix this winsock2.h and ws2tcpip.h I can't get pass this, what should I do.

Thanks for helping

c:\mingw\bin\../lib/gcc/mingw32/4.6.2/../../../../include/ws2tcpip.h:38:2: error
: #error "ws2tcpip.h is not compatible with winsock.h. Include winsock2.h instea
d."
In file included from src\/schnorr.h:11:0,
                 from src\/hash.h:17,
                 from src\/net.h:22,
                 from src\rpcnet.cpp:6:
src\/cryptopp/osrng.h:43:0: warning: ignoring #pragma comment  [-Wunknown-pragma
s]
In file included from src\/compat.h:17:0,
                 from src\/netbase.h:11,
                 from src\/net.h:19,
                 from src\rpcnet.cpp:6:
c:\mingw\bin\../lib/gcc/mingw32/4.6.2/../../../../include/ws2tcpip.h:147:8: erro
r: redefinition of 'struct ip_mreq'
c:\mingw\bin\../lib/gcc/mingw32/4.6.2/../../../../include/winsock.h:315:8: error
: previous definition of 'struct ip_mreq'
c:\mingw\bin\../lib/gcc/mingw32/4.6.2/../../../../include/ws2tcpip.h:390:13: err
or: expected initializer before 'freeaddrinfo'
c:\mingw\bin\../lib/gcc/mingw32/4.6.2/../../../../include/ws2tcpip.h:391:12: err
or: expected initializer before 'getaddrinfo'
c:\mingw\bin\../lib/gcc/mingw32/4.6.2/../../../../include/ws2tcpip.h:393:12: err
or: expected initializer before 'getnameinfo'
In file included from src\/cryptopp/pubkey.h:35:0,
                 from src\/cryptopp/eccrypto.h:7,
                 from src\/schnorr.h:12,
                 from src\/hash.h:17,
                 from src\/net.h:22,
                 from src\rpcnet.cpp:6:
src\/cryptopp/modarith.h: In copy constructor 'CryptoPP::ModularArithmetic::Modu
larArithmetic(const CryptoPP::ModularArithmetic&)':
src\/cryptopp/modarith.h:29:2: warning: base class 'class CryptoPP::AbstractRing
<CryptoPP::Integer>' should be explicitly initialized in the copy constructor [-
Wextra]
In file included from src\/cryptopp/simple.h:10:0,
                 from src\/cryptopp/filters.h:6,
                 from src\/cryptopp/randpool.h:5,
                 from src\/cryptopp/osrng.h:10,
                 from src\/schnorr.h:11,
                 from src\/hash.h:17,
                 from src\/net.h:22,
                 from src\rpcnet.cpp:6:
src\/cryptopp/misc.h: In function 'std::string CryptoPP::IntToString(T, unsigned
 int) [with T = unsigned int, std::string = std::basic_string<char>]':
src\/cryptopp/simple.h:35:128:   instantiated from here
src\/cryptopp/misc.h:414:2: warning: comparison of unsigned expression < 0 is al
ways false [-Wtype-limits]
Makefile.Release:3231: recipe for target 'build/rpcnet.o' failed
mingw32-make: *** [build/rpcnet.o] Error 1
  • I tried replace the content of ws2tcpip.h with winsock2.h - That's almost definitely the wrong thing to do, those files are not interchangeable. If you've modified the system header files, then your build system is now broken. You will need to fix your build system first, before you can build software with it. – Greg Hewgill Mar 30 '14 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.